Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This is an odd one. I've installed linux (both ubuntu 9.10 and debian 5) on vitualbox running on OS X. The install is fine, and once I switch the networking over to bridged I'm able reach the web and ssh into other boxes.

However, I can't scp into the virtual machine. From within the guest OS I start an scp command to copy to the box, and it stalls with 0% complete. I can ssh just fine, but scp fails.

Similarly apt-get install fails, while apt-get update works fine.

I thought it was something to do with the networking setup on the guest OS, but I've tried with both Ubuntu and Debian and both behave exactly the same way. Is there a virtualbox or an OS X setting prevent transfers over a certain size to the guest OS?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

This turned out to be an issue with the VirtualBox setting - the adapter type was set to PCFast (or something like that), switched it to Intel Pro and it started working. Well, Debian did, ubuntu is still not cooperating.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.