Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running Windows Server 2008 Standard Edition R2 x64 and I installed SQL Server 2008 Developer Edition. All of the preliminary checks run fine (Apart from a warning about Windows Firewall and opening ports which is unrelated to this and shouldn't be an issue - I can open those ports).

Half way through the actual installation, I get a popup with this error:

Could not continue scan with NOLOCK due to data movement.

The installation still runs to completion when I press ok.

However, at the end, it states that the following services "failed":

database engine services sql server replication full-text search reporting services

How do I know if this actually means that anything from my installation (which is on a clean Windows Server setup - nothing else on there, no previous SQL Servers, no upgrades, etc) is missing?

I know from my programming experience that locks are for concurrency control and the Microsoft help on this issue points to changing my query's lock/transactions in a certain way to fix the issue. But I am not touching any queries?

Also, now that I have installed the app, when I login, I keep getting this message:

TITLE: Connect to Server

Cannot connect to MSSQLSERVER.


A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) (Microsoft SQL Server, Error: 67)

For help, click:



I went into the Configuration Manager and enabled named pipes and restarted the service (this is something I have done before as this message is common and not serious). I have disabled Windows Firewall temporarily. I have checked the instance name against the error logs.

Please advise on both of these errors. I think these two errors are related.


share|improve this question

Did you configure your server to accept external connections? BY default SQL disables connections from other machines.

If that is not the case, try switching your connection method to TCP/IP as default for both server and client and see if you still get the error.

Make sure that the MSSQLSERVER service is running. Check if you can connect to the SQL server using client tools on the server.

share|improve this answer

I'm getting the same error as well.

In my case, I have a table that has ~6000 rows. A job inserts calculates new rows from other data source and inserts it into this table, making row count ~12000. Then the same job deletes the previous rows, to ensure several business requirements. ("truncate before / insert afterwards" is not possible in my case).

And there are other queries that use select with nolock's to read from the table. I am guessing the error implies that just after SQL Server found which record to read from, the row has been deleted.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.