Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I know PHP is working, because when I browse directly to a file in wwwroot, it's served fine. And the virtual directory is working, because when I browse to html files in the virtual directory, they're served. But when I browse to a PHP file in the virtual directory, I receive an HTTP 500 error from IIS.

Searching on the web, I found a bunch of suggestions to confirm that doc_root in php.ini is blank - however, it is and it's still not working.

Other configuration settings going on: Integrated Windows authentication is turned on, client certificates are required, and client certificate mapping is enabled. All of it is working fine for PHP content not in a virtual directory.

Thanks for any suggestions!

share|improve this question
add comment

1 Answer

See what you can to do find out which 500 error you're getting. Make sure that you have IE friendly errors turned off (if you're using IE), and if you still don't get a good error, check the IIS logs to get the 500 sub-status code. That will likely give a big clue as to the exact error and what to do about it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.