Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

IIS 7.5 on Windows 7 x64 Ultimate is missing the Management Service icon which is present in IIS 7.5 on Windows Server 2008 R2. Is it possible to enable it, or is it possible to access the Management Service configuration panel in another way?

Edit 1:

After enabling Web Management Service on both Windows Server 2008 R2 Web Edition 64 bit and Windows 7 Ultimate 64 bit, I got the following result:

  • IIS Manager running on the Win 2008 provides the following icons

enter image description here

  • But IIS Manager running on the Win 7 provides only the following icons

enter image description here

share|improve this question
    
I have the same problem. I have enabled Web Management Service on Windows 7 Ultimate 64 bit. But the Management Service icon does not exist in the IIS Manager. It is not the case on Windows Server 2008 R2 64 bit. What is wrong? –  LaTeX Feb 28 '11 at 2:05

5 Answers 5

Remote Administration against a Windows client SKU (like Windows 7 or Windows Vista) is not supported (WMSVC will not allow connections). That means that the Management Service UI is not required not supported on those SKUs. If you want to allow Web Deploy support to do remote publishing to client SKUs you will need to use the Web Deploy remote service.

share|improve this answer

This isn't always enabled. You can enable that from Server Manager -> IIS -> Add Roles.

share|improve this answer
1  
Hi, this is on Windows 7 and the Management Service is installed already from "Turn Windows features on or off". Thanks –  Miky Nov 25 '09 at 10:37
    
Oh right, Win 7 doesn't support remote management. That's one of the very few features that require server. AFAIK the management service is only used for FTP features and IIS Manager users. So, to answer your original question, it's not possible. Microsoft wants you to use Server 2008 if you have remote management needs. –  Scott Forsyth - MVP Nov 25 '09 at 18:49
    
Hi Scott, thank you for your reply. It's actually for web app deployment using MSDeploy. I know it's configured to listen on port 8172, I just need to change the settings but as it seems, the UI config panel is not present in Windows 7. I read somewhere that it may be possible to change the settings using PowerShell. –  Miky Nov 26 '09 at 2:09
    
Hi Miky, I'm not sure if it's possible, but the place to start looking would be HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WebManagement\Server. That's the key where the settings are for Server 2008. –  Scott Forsyth - MVP Nov 26 '09 at 5:04
    
Hi Scott, I had already checked that key but it's empty on Windows 7. I'll check around for a solution. Thanks. –  Miky Nov 26 '09 at 19:01

These instructions are for Windows 7 only. MS has made it a pain to remotely manage IIS, but it may be in an effort to make it more secure. Windows 7 further complicates things by not including everything to remotely manage IIS 7 & 7.5. First one needs to install the IIS Manager Console in Programs & Features, then download and install the following: http://www.microsoft.com/downloads/details.aspx?FamilyID=32c54c37-7530-4fc0-bd20-177a3e5330b7&displaylang=en

IMHO, this component should be installed when RSAT is installed, but MS decided to make it separate. After the remote management component is installed, one may remotely manage a remote server as long as the IIS Management Service is configured and enabled on the remote server.

share|improve this answer
    
@Fuzzball: After Web Management Service, IIS Manager does not show the Management Service icon. So how to manage delegation? –  LaTeX Feb 28 '11 at 2:12

This route will solve your problem, I find you cost much greetings

http://www.microsoft.com/web/downloads/platform.aspx

share|improve this answer
1  
Hi Paco, we only accept answers in english here, so I have run this through Google Translate. Please improve it as nessesary. –  Mark Henderson Oct 30 '11 at 0:47

To enable IIS Management Service in Windows 7 go to

Control Panel > Programs > Turn on Windows features on or off. 

Look for the node for

Internet Information Services > Web Management Tools > IIS Management Service.

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.