Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to provide machines on a small LAN with read-only, anonymous access to files shared from a Windows 7 workstation (let's call it WIN7SVR). In particular, I don't want clients to have to deal with a login window when they navigate to, e.g., \\WIN7SVR in Windows Explorer, but we do not have a domain and synchronizing accounts between the server and clients would be intractable. There are both Windows 7 and Windows XP clients that need access to these shares.

I got this working for Windows 7 clients by just enabling the Guest account on WIN7SVR and setting appropriate share permissions. Other Windows 7 machines automatically try logging in as Guest, it seems, so their users don't have to deal with the login window. The problem is with the XP clients--they can access the server if the user enters "Guest" in the login window, but I don't want users to have to do that. So from what I gather, in my limited understanding of Windows file sharing, this boils down to granting null sessions access to file shares on WIN7SVR.

But I've had no success so far on that front. I've tried all the following in the local group policy editor on the Windows 7 server:

  • Set Network access: Let Everyone permissions apply to anonymous users to Enabled
  • Set Network access: Restrict anonymous access to Named Pipes and Shares to Disabled
  • Added the names of corresponding shares to Network access: Shares that can be accessed anonymously
  • Added "ANONYMOUS LOGON" to Access this computer from the network under User Rights Assignment

Any advice would be highly appreciated... I'm mostly a Unix guy, so I feel somewhat out of my league with Windows file sharing. I do understand that any sort of anonymous access to file shares isn't generally ideal from a security standpoint, but it's the most practical solution for us in this case, and access to our network is well enough controlled that share-level security isn't a concern.

share|improve this question

4 Answers 4

up vote 0 down vote accepted

This might be completely off, but do the XP clients have simple file sharing enabled? And are they XP pro or home?

To check on simple file sharing:

  1. Open an explorer window
  2. Click Tools, Folder Options
  3. At the bottom of the list is the checkbox for simple filesharing.
share|improve this answer
    
The XP clients are XP Pro, and they have simple file sharing disabled. Thank you for the suggestion, but I tried enabling simple sharing on one of the XP machines and it didn't make a difference. –  Niten Nov 25 '09 at 20:00
    
Unfortunately I never got to the bottom of this, but we eventually did a fresh reinstall on the XP Pro machines and now your solution works as expected. –  Niten Aug 8 '10 at 7:26

Couldn't get this to work for a while too. The problem only happens with some XP installations but never with seven.

This solved the problem for me, hope it will help some people!

Network sharing on Server 2008 asking for login

share|improve this answer

Try enabling the guest account:

  • Computer Management > Local Users and Groups > Users
  • Right click Guest > Properties
  • Untick "Account is disabled"

Enabling this account worked to resolve this issue for me on Windows Server 2008 R2.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.