Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have several Vista hosts each with one Ubuntu guest each running in virtual box in bridge mode.

All guests can resolve internal DNS except one.

On the problematic guest machine, if i dig @<internal dns ip> <some internal domain> it always gives timeout, but on that machine, the <internal dns ip> replies to pings and i can even telnet <internal dns ip> 53.

I've checked, and the windows firewall on the host is disabled.

Any ideas on what could be the problem?

Thanks, Joel

share|improve this question

4 Answers 4

Fixed.

The host user had installed some kind of VPN client that was blocking DNS traffic created by the guest.

share|improve this answer

Compare resolv.conf on problematic and normal machine. Also, check IP configuration.

and iptables -F

share|improve this answer
    
They are the same. iptables isn't installed. –  Joel Nov 25 '09 at 11:40

Usually Bridge mode problems are due to improperly configured guest network settings or a problem with DNS.
If you are trying to use DHCP and it does not work then try setting Static address and see if this helps. Selecting an external DNS server can also help.

Found here.

share|improve this answer
    
> Selecting an external DNS server He needs to resolve internal DNS –  TiFFolk Nov 25 '09 at 10:14
    
This is the first part of my answer. –  Andrejs Cainikovs Nov 25 '09 at 10:16
    
it's already static. even using external dns doesn't work –  Joel Nov 25 '09 at 11:41
    
@Joel: That means, you have problem with connecting to 53 UDP port. Try dumping traffic as RainyRat said. –  TiFFolk Nov 25 '09 at 12:32

If neither of the other two answers are helping you, you could always try grabbing some DNS traffic with Wireshark or something similar, then looking for the actual DNS conversation. Make sure to do it somewhere you can see both sides of the conversation (i.e, is the problem that DNS requests aren't making it to the server, or replies aren't making it back to the client?)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.