Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to host a website on my server to which I want to allow anonymous access.

I have purchased a domain name from Go-Daddy and changed the A/MX-Record to point to my server (as I am also running Exchange Server, before I get lectured on how this is a bad idea please see my other question Running ASP.NET Website and Exchange Server on same machine?).

So at the moment when I navigate to my domain it does indeed go to my server as I am presented with the standards Welcome to Windows Server 2003 page. However, I don't want this to happen I wan't to re-direct any requests coming to my server from my new domain to a different website folder.

What I did so far was...

1) Opened up IIS Manager
2) Created a new Web Site
3) Set the host header of the Web Site to be my new domain
4) Made sure that Anonymous access was enabled.

This all worked fine, however, whenever I navigated to my domain it kept prompting me to log in. Once logged in it would display all the content of the page, otherwise it would not.

So I then went to the particular folder and in the Web Sharing tab I try to enable sharing for the new web site I have created. However, everytime I enabled it for my website and applied it, going back in and checking it it was always going back to "Do not share".

Please help me its driving me insane!

share|improve this question

Sharing? You need to check the file and folder permissions on the place where that website is placed. Whatever account your IIS runs anonymous access under needs to have read access to the website files... this was/is normally IUSR_ but could differ depending on setup.

Does this server also serve as a domain controller?

Here's a related issue answered at SO.

Also, what do the event logs say when the prompts occur? It could be a lot of issues from a broken IIS guest account password sync to a full security log ^^

share|improve this answer
Yes it is using the IUSR login, it could be the permissions of this account the more I think about it as it is the C: drive. – James Nov 25 '09 at 14:24
I checked this account and it is part of the "Users" group which has read access to that particular folder and to my WebSite. – James Nov 25 '09 at 14:48
I have tried everything, created a virtual directory, sync'd the AD/IIS metabase and MTA passwords and still cant get it!!!! – James Nov 25 '09 at 20:12
up vote 0 down vote accepted

Figured out what I was doing wrong...

I was checking the "run scripts (such as ASP)". I think because of this I would have to grant the IUSR_MachineName account access to the ASP.NET framework dlls (in the system folder).

As this is just a static site unchecking this option seems to resolve the issue!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.