Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running a ubuntu-server in a VirtualBox and need to configure the terminal to access internet through the proxy.

I've tried:

export http_proxy=http://USERNAME:PASSWD@proxy.mycompany.com:8080

I'll show the output in a simple wget debug mode tentative:

$ wget http://nexus.sonatype.org/downloads/nexus-webapp-1.3.6-bundle.tar.gz -d

DEBUG output created by Wget 1.11.4 on cygwin.

--2009-11-25 16:35:31--  http://nexus.sonatype.org/downloads/nexus-webapp-1.3.6-bundle.tar.gz
Resolving proxy.mycompany.com... 192.168.0.10
Caching proxy.mycompany.com => 192.168.0.10
Connecting to proxy.mycompany.com|192.168.0.10|:8080... connected.
Created socket 3.
Releasing 0x00690ac0 (new refcount 1).

---request begin---
GET http://nexus.sonatype.org/downloads/nexus-webapp-1.3.6-bundle.tar.gz HTTP/1.0
User-Agent: Wget/1.11.4
Accept: */*
Host: nexus.sonatype.org
Proxy-Authorization: Basic cmMhc3RhtyuiOlN1cHBheeQyMDA9

---request end---
Proxy request sent, awaiting response...
---response begin---
HTTP/1.1 407 Proxy Authentication Required ( The ISA Server requires authorization to fulfill the request. Access to the Web Proxy service is denied)
Via: 1.1 MAXIN00
Proxy-Authenticate: Negotiate
Proxy-Authenticate: Kerberos
Proxy-Authenticate: NTLM
Connection: Keep-Alive
Proxy-Connection: Keep-Alive
Pragma: no-cache
Cache-Control: no-cache
Content-Type: text/html
Content-Length: 4106

---response end---
407 Proxy Authentication Required ( The ISA Server requires authorization to fulfill the request. Access to the Web Proxy service is denied)
Closed fd 3
2009-11-25 16:35:31 ERROR 407: Proxy Authentication Required ( The ISA Server requires authorization to fulfill the request. Access to the Web Proxy service is denied)

Does some one could give me any tip?

Thanks in advance

share|improve this question
    
3k views and no up votes, I did something wrong? –  rafa.ferreira Feb 16 '11 at 13:30

2 Answers 2

up vote 2 down vote accepted

The problem is that wget only supports basic auth to proxies, and your proxy doesn't accept that sort of authentication. Your options are:

  1. Patch wget to support one of the accepted methods of authentication
  2. Get your proxy admin to allow basic auth
  3. Don't use a proxy
  4. Use a different proxy (either one that doesn't require auth, or which accepts basic auth)
share|improve this answer
    
You are completely right! I have just checked here with support guys, and they put basic auth in proxy for a moment and all works. I thought that is a configuration in bash not in wget. I'll googled to check if I could define digest or integrate auth. Thanks womble –  rafa.ferreira Nov 25 '09 at 19:08
    
Just adding more info to my comment. apt did not work with non-basic auth, and many others software. So I'll try to convince my company to authorize basic auth, or try some other workaround. But thanks womble! –  rafa.ferreira Nov 25 '09 at 19:47

Use ntlmaps, a Python proxy you can run on your local machine and handles NTLM auth.

You edit the config for ntlmaps with the settings from the ISA proxy and then point the http_proxy to the local ntlmaps proxy.

share|improve this answer
    
I tried to set my apt-get proxy as described here: askubuntu.com/questions/23666/apt-get-does-not-work-with-proxy and configuring apt.conf to the localhost and then using ntlmaps worked where direct edit of apt.conf to the same settings didn't. –  monkut May 2 '13 at 6:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.