Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

from one week ago, I have a problem by my IIS, I get response time out and each of my web sites can't be opened. I have to restart IIs.

Many Times this accrue on mid night and when we dont have alot of visitor. how can I find more details and find a solutions? I checked task manager w3wp process with a lot of memory usage.

Thanks.


Server information: Windows 2003 standard Ed Asp.net 1.1 2 3 3.5 3.5 sp1 SQL server 2005 2008 express php 4 5 mysql 4 5

share|improve this question
    
Can you describe the technologies running under that w3sp process? Is it an ASP.NET or PHP site? –  p.campbell Nov 26 '09 at 3:48
    
Are you restarting IIS because an application pool recycle doesn't work? Are your sites separated out or are you trying to run them all under one app pool? –  phoebus Nov 26 '09 at 6:54
    
I have both php and asp.net web site, I have 3 application pool , one for asp.net 1.1 , another for asp.net 2 and the latest for php. how can I find which is related to this process? –  Ashian Nov 26 '09 at 11:06
    
I checked again and see just asp.net web sites have this problem and others work –  Ashian Nov 26 '09 at 17:22

2 Answers 2

up vote 0 down vote accepted

From your comments on the original question, it looks like only your ASP.NET websites are having the problem.

First, see if recycling that app pool will fix the issue, instead of a full IIS restart, as that closes user TCP connections while a recycle does not. If you need to narrow down particular process IDs to app pools, use iisapp at the command line to get a list of app pools by w3wp PIDs.

Now, if you've narrowed it down to a particular app pool, make more app pools of that ASP.NET version and split the web sites among them so that it is one website to one app pool. This way you can narrow down exactly where the issue is.

If you find the site with the issue, keep it in a separate app pool, and try setting a periodic or specific time recycling schedule. Since this issue is happening consistently, doing so may solve your problem.

share|improve this answer
    
Hi,I changes some site AppPool and use dedicated app pool. Currently less error occurs. and if occurs after some times it will back to normal state without IIS restart. but still I cant find where the issue is. –  Ashian Dec 1 '09 at 8:07
    
At this point, the issue is likely in that site's code. Auto-recycling and such are stopgap measures to keep sites up and running, but are not a permanent substitute for proper code review. –  phoebus Dec 1 '09 at 8:21

Watch w3wp throughout the day and evening to see if it grows. It sounds like it may be a memory leak. Also watch the system resources just before it occurs to see if disk IO, memory, CPU or another resource is a problem. Also check Event Viewer in case there is an error logged. The IIS logs may give some clues from when the error changes from a 200 status code to something else.

Finally, see if any scheduled tasks or backups start at midnight.

share|improve this answer
    
I have a backup task ( windows back up) that runs at the 2 AM , but this task was active from 6 month ago, but my problem start from last week –  Ashian Nov 26 '09 at 9:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.