Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We have a endian firewall setup on a Centos box for our company branch office. Now the problem is the following some sites eg. do not work when trying top open them up in browser, getting DNS error.

So what I did I switched off the firewall and still it did not work. Then I ssh'd into the firewall PC and tried to PING and I got

ping: unknown host

So I tried to PING using the IP

I got the following

ping; PING ( 56(84) bytes of data. and then it does nothing, I rebooted the PC and still nothing.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

A few other things to consider:

  • Checking the output of "traceroute", both from the firewall and one of your client PCs might tell you where the traffic's going (or rather, where the traffic's stopping).
  • Also, what's your DNS setup like? Do you run it internally, or use your ISP/OpenDNS/whoever for resolution?
  • What happens if you query your nameserver directly with nslookup or dig? If you've got an internal nameserver, try checking both that and whatever server it refers queries out to. It's possible that your firewall's somehow blocking outbound DNS.
share|improve this answer
traceroute just hangs – Roland Nov 26 '09 at 13:24
although traceroute works – Roland Nov 26 '09 at 13:25
OK, try "traceroute -n" instead; that'll stop it trying to do a DNS lookup on everything it encounters on the way. Sorry, should have said. – RainyRat Nov 26 '09 at 13:55
I appreciate your help. I now get traceroute -n traceroute: unknown host – Roland Nov 26 '09 at 14:50
This is how the resolv.conf file looks cat /etc/resolv.conf nameserver – Roland Nov 26 '09 at 14:50

What is your DNS servers? (cat /etc/resolv.conf)

Try to add\change them to other

share|improve this answer
This is how the resolv.conf file looks cat /etc/resolv.conf nameserver – Roland Nov 26 '09 at 13:23

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.