Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I recently put two new Windows 7 Professional machines into a dated network environment. The server is running Windows 2000 Professional (Workstation, not server) and I can't get the Windows 7 machine to connect to it. There is no domain for this network.

On the server (We'll call it data1, the Network share is shared with everyone (i.e., everyone who has a local account on the machine). When I go to connect to it on one of the Windows 7 machines, I get a prompt for a network password. I have tried all accounts on the server using the domain prefix like data1\user. But it doesn't connect - a "invalid username or password" error comes every time.

For a stopgap solution while I get this worked out, I built a new server of off Windows Server 2003. All machines can connect to it (Windows 2000, Windows XP and Windows 7).

Is it just that Windows 2000 is too old to connect to Windows 7? Thanks for your help.

share|improve this question

6 Answers 6

LmCompatibilityLevel as already suggested plus look at secpol.msc -> local policies -> security options -> lan manager auth level. as far as I remember Win7 uses NTLM2 by default, try setting it to "LM & NTLM, NTLM2 if available" or so.

share|improve this answer
    
I started to have the same problem but after a windows update, before that everything was working great, solved it using disserman solution... Thanks! –  user116184 Apr 2 '12 at 19:37

I think this is to do with the LmCompatibilityLevel.

I have had to add this to our new Windows 7 clients to enable them to access the NAS as it runs an older version of Samba that doesn't support the version of NTLM that Windows 7 is trying to connect with.

Try adding a DWORD value of "LmCompatibilityLevel" with a value of "1" to:

HKLM\SYSTEM\CurrentControlSet\Control\Lsa

It won't exist so you'll have to make it. Restart machine and you should be good to go.

This is the registry hack mentioned by Nick.

share|improve this answer
1  
+1 The NTLM Level is most likely the problem... Good call... –  Dscoduc Nov 28 '09 at 19:35

Why don't you just continue to use the Windows 2003 Server instead of the Windows 2000 Workstation?

You already have it built...

share|improve this answer
3  
Because it won't help anyone else who comes accross this question in 3 months time with the same situation –  Mark Henderson Dec 17 '09 at 22:13

Are the computers in an Active Directory Domain, or are they in a workgroup?

If they're in a workgroup, then read this: Accessing a Shared Folder or Printer with Windows Vista. I know it says Vista, but it's the same thing! (shh!!!)

As discussed. Make sure that your windows 2000 client supports NTLMv2 (latest service pack should help) or you can break windows 7 so that it will support NTLMv1 via a registry hack.

share|improve this answer

Have a similar problem. I have tried setting the lan manger auth level to LM & NTLM - use NTLMv2 session security if negotiated, Send LM & NTLM responses, and NTLM response only. None seem to work.

share|improve this answer

After a power outage, my Windows 7 laptop again could not find my Windows 2000 box. I had to reset the LmCompatibiltiyLevel to its original setting and then back to "1" before the Windows 2000 was visible again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.