Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to use mod_disk_cache to speed up a web site that is running on WordPress. Whenever I enable it with

CacheEnable disk /

and the rest being the stock Ubuntu configuration I start to get the wrong results. When I see the main page it's fine, but when I go to a specific post I get a RSS feed instead. Like if the cache is returning the wrong content.

I've disabled my RewriteRules as it seems mod_cache doesn't work with that.

I'm not even sure where to start to debug such a thing. Any ideas?

share|improve this question

Making a small change to the Rewrite rules in your .htaccess file should solve this. There is, apparently, a known bug in apache. I had the exact same problem, albeit a different flavor of unix (FreeBSD), and the fix given at this link below absolutely solved it:

share|improve this answer
up vote 0 down vote accepted

I couldn't found why this was happening but I solved it by using WP Super Cache; which greatly increased the performance of my Wordpress.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.