Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Windows 7 keeps asking for a password every time I mount a webdav.

I don't want to store a password in a .bat file because it's so insecure.

Is there any way to force system store it? Manually adding credentials in user manager helps storing passwords for SMB shares but for webdav doesn't.

btw, as far as I remember, Vista had the same problems.

share|improve this question
add comment

2 Answers

If you are using basic authentication, then unfortunately, Windows 7 doesn't allow this

http://support.microsoft.com/kb/2673544

In Windows 7 Basic authentication cannot be persisted by the Credential Manager in Windows 7, this is new to the OS. The only way with Basic authentication mode to reconnect is to disconnect the drive and reconnect again, because WinHttp is not able to retrieve saved Basic and Digest credentials. For persistent connections ensure that an authentication scheme is selected that allowes to have persistent credentials through a reboot. For example Kerberos for authentication or certificate based authentication will work.

If you are using integrated windows auth, then there is a reg setting you need to enable to allow it to work.

http://support.microsoft.com/kb/941050

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters
AuthForwardServerList (MULTI_SZ)

Add the name of the Server there

share|improve this answer
add comment

Adding the address of the WebDAV host to your Internet 'Trusted Sites' zone may work around this issue.

share|improve this answer
    
unfortunately doesn't –  disserman Feb 7 '10 at 12:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.