Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I connect to a remote host:

desktop$ ssh -X user@remote

and start firefox:

remote$ firefox &

I expect firefox to be run on remote and also all traffic should be sent to internet using remote's ip. This is not happening. Is there any ssh option to make it act that way?

share|improve this question

3 Answers 3

up vote 1 down vote accepted

You need to tell firefox on the remote machine to not worry about your currently running instance. Use the cli arg of -no-remote to do this:

remote$ firefox -no-remote &

share|improve this answer

Given the behaviour you're experiencing, I find it likely that Firefox is detecting the existence of a session already running on the X server (desktop) and telling that session to open a new window.

This would give the behaviour you're experiencing.

Otherwise, it should behave exactly as you describe. Firefox (the X client) doesn't care where the X server that it's talking to is located; all traffic originated from Firefox comes from the host that it's running on.

share|improve this answer

Another option (and it might provide better performance) is to set up an SOCKS proxy using ssh. For example

ssh -D 8675 remote

And then set your local browser to use localhost:8675 as the proxy.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.