Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm using a VPS running Virtuozzo Containers with Parallels. Every time I reboot it sets the server's TimeZone to GMT+01 Amsterdam. If I change that to GMT+00 London and then reboot, it gets set back to Amsterdam again. Is there any way I can prevent this?

I'm also have a very strange issue whereby .Net is reporting that the DateTime.Now as the +01 Amsterdam time instead of +00 GMT, even after I've change it to London's TimeZone.

Is there somewhere else I need to change the TimeZone apart from in the Timezone tab under the system clock?

share|improve this question
add comment

2 Answers

What version of Virtuozzo are you running? This looks a lot like a bug in Virtuozzo version 3.5.1 that was completely fixed in versions 4 and beyond.

share|improve this answer
add comment

After having it be pointed-out that I missed the "Windows" reference, it sounds like the underlying virtualization layer is holding time permanently - perhaps, as has been mentioned elsewhere, as a bug in the edition of Virtuozzo.

This is probably an issue you need to take up with your VPS provider.

original answer below
Might check hwclock, but it sounds like the VPS's settings require it to go back to the underlying host's timezone setting.

share|improve this answer
    
Pointing at a linux manpage for a Win2k3 server? –  womble Nov 29 '09 at 22:46
    
honestly - missed the tag for "windows-server-2003": nothing in the question indicated platform :) –  warren Nov 30 '09 at 0:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.