Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am having a hard time migrating my MySQL 4.1 database from old 16-byte password hashes to the new 41-byte hashes. The problem is, that the mysqld server automatically starts with the "old-passwords = on" directive, which restricts setting new passwords to 41-bytes length.

My question: Does anyone know how I can tell mysqld to run without the "old-passwords = on" directive? I tried my.ini, commmandline, setting the variable locally, but nothing worked.

Thanks a lot! Philipp

share|improve this question
    
What OS is this? –  Nathan Adams Nov 29 '09 at 18:00
add comment

3 Answers

Have you looked in /etc/my.cnf or /var/lib/mysql/my.cnf, maybe is is set there? BTW, the directive is old_passwords (underscore, not dash)

share|improve this answer
    
I found out that I had to set the flag "old-password=0" in my my.ini config file. It is very important to set this option in the correct section of the ini-file. Section names seem to correspond with windows service names: In my case, the windows service name is "MySQL4" - unfortunately this section had to be manually created, as the default name after setup seems to be "mysqld". All the best! –  Philipp Dec 5 '09 at 12:09
add comment

I'm thinking this is a Windows box -
Just edit my.ini and set
"old_passwords=0"
Or comment/delete the line that sets old_passwords

share|improve this answer
    
I found out that I had to set the flag "old-password=0" in my my.ini config file. It is very important to set this option in the correct section of the ini-file. Section names seem to correspond with windows service names: In my case, the windows service name is "MySQL4" - unfortunately this section had to be manually created, as the default name after setup seems to be "mysqld". All the best! –  Philipp Dec 5 '09 at 12:10
add comment
up vote 0 down vote accepted

I found out that I had to set the flag "old-password=0" in my my.ini config file. It is very important to set this option in the correct section of the ini-file. Section names seem to correspond with windows service names: In my case, the windows service name is "MySQL4" - unfortunately this section had to be manually created, as the default name after setup seems to be "mysqld". All the best!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.