Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

i'm running an NT Server - when trying to delete eg. just one file - it takes several minutes (!!) until the file gets deleted. i'm only getting the deleting-dialog but nothing happens.

any ideas what could be wrong?

thx

share|improve this question

migrated from stackoverflow.com Nov 29 '09 at 19:04

This question came from our site for professional and enthusiast programmers.

    
Oh... yeah, other people are right: This question belongs on Superuser.com or Serverfault.com . –  Carl Smotricz Nov 29 '09 at 14:36
2  
How big is the file, how much free space is there on the filesystem, and does it perform the same way when you try deleting it from the command line? –  Matt Simmons Nov 29 '09 at 19:49
    
Have you tried checking the disk for errors? –  John Gardeniers Feb 4 '10 at 3:41
1  
NT Server? From which century? (ie which version) ^^ –  Oskar Duveborn Jun 27 '10 at 7:35

3 Answers 3

up vote 3 down vote accepted

This can also be caused by a very full recycle bin, or deleting files from a directory that has way too many files, or a fragmented MFT (especially in NT4.0 NTFS).

share|improve this answer

I'd guess it's deleting into an already overfull garbage can. Try SHIFT-Delete!

share|improve this answer

I assume that the problem is on a local disk, not network connection.

1) If you have some kind of real time antivirus protection, disable it and see if the problem persists

2) Do a CHKDSK on that file system

3) If you are deleting via Explorer interface, check the trashcan and try to delete file via CMD command line interface and see if the problem persists

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.