Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My Windows drives are automatically mounted in Ubuntu. File operations on Windows drives had been going well until today when creating a directory on a nfts Windows drive is denied:

$ mkdir /windows-d/tmp  
mkdir: cannot create directory `/windows-d/tmp': Operation not supported

Some permission info is:

$ ls -l / | grep "windows-d"  
drwxrwx--- 1 root plugdev 229376 2009-11-28 20:28 windows-d

Reboot Ubuntu doesn't solve my problem.

I wonder what's wrong with it?

Thanks and regards!

share|improve this question
What have you changed since the last time it worked? – womble Nov 30 '09 at 1:03
What's the grep for? ls -ld /windows-d – Dennis Williamson Nov 30 '09 at 1:26
Nothing particularly as far as I remembered. But you know I might do things whose meanings I am not aware of. Thankfully, I finally solved this problem, but not sure how exactly. My /windows-d has only about 500M left free. So I delete some files and got 1.2G free. At the same time I updated my system. After reboot, it works again. I am not sure it is because of my low free space. It happened before but no problem arose then. – Tim Nov 30 '09 at 1:30
@Dennis, I am so dumb that I didn't know to use ls -ld. Thank you for I have learned it. – Tim Nov 30 '09 at 1:32
@Tim: Funny, that question was cross-posted across to! Glad it worked! :) – t0mm13b Nov 30 '09 at 2:29

it's possible that the windows side did not shut down correctly (or was not dismounted in windows) that can lead to Ubuntu mounting it read only, or if it's still mounted under windows. some thing simple but about the only thing i can think of.

share|improve this answer
The problem happened in the middle of my operations. All was fine before then. It is not that windows did not shut down correctly, Some text files could still be writeable. But making directories failed. – Tim Nov 30 '09 at 1:35

I had a similar problem with a Flash Drive from my Camera, that was plugged into Windows before I switched to Unix.

I got "Operation not permitted" when trying to rm -f the file winamp_cache_0001.xml. chown also did not work. So I went to the Mac Disk Manager and deleted the whole Flash drive. That worked.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.