Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am trying to install subtext via the Web Platform Installer on my Windows server 2008 VPS.

To install it I need the .net framework version 3.5 SP1. It actually fails definetly each time I try, so I tried to install the SP1 manually. I failed with the error message :

[11/30/09,02:40:01] Microsoft .NET Framework 2.0SP1 (x64) (CBS): [2] Error: Installation failed for component Microsoft .NET Framework 2.0SP1 (x64) (CBS). MSI returned error code -2147467262
[11/30/09,02:40:05] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0SP1 (x64) (CBS) is not installed.

When I tried to install the .net 2.0 SP1 x64 it says that it is not supported by vista (?!). I tried to clean up every .net version of my server using the cleanup tool and then install the 3.5sp1 back (and even 2.0sp1) both failed with same error codes.

I am not able to use the Windows update since it is a virtuozzo VPS (and it is said that if I use Windows update it will break my VPS because updates are streamlined by Virtuozzo... ) but the windows update service is started.

Any hints on solving this issue ?

[edit]

Currently the versions installed are :

  • .Net 2.0.50727.1434
  • .Net 3.0.4506.648

[edit-2] Here is a screenshot of my server manager:

enter image description here

share|improve this question

2 Answers 2

The installer is trying to connect to the internet. Try Microsoft. NET Framework 3.5 Service pack 1 (Full Package) http://www.microsoft.com/en-us/download/details.aspx?id=25150

share|improve this answer

The .NET Framework 3.0 is included in the base installation for Server 2008. However, it's a "Feature" that must be enabled in Server Manager. Once the feature is enabled, Windows Update should pick up the additional patches and service packs for it.

share|improve this answer
    
Already there... I need the 3.5 SP1. –  Erick Nov 30 '09 at 8:59
    
I added a picture of the server manager ... –  Erick Nov 30 '09 at 20:57
    
Without spinning up a new 2008 VM, I'm not really sure then. Usually we let Windows Update take care of installing additional .NET pieces. But I don't know whether 3.5 is considered critical or optional. –  Ryan Bolger Dec 1 '09 at 0:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.