Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Actually several problems. Let me explain what we are trying to accomplish first:

We have a server that sits in two subnets, by having a network adapter plugged into each network. 192.168.10.x and 192.168.20.x are the subnets. The 20.x subnet in intended for external access (outside the office, our 'DMZ' of sorts), and 192.168.20.1 is the gateway to the outside world. If a user or app on the server tries to access yahoo.com, for example, it should be routed through the 20.x subnet. The 10.x subnet is internal only and traffic to outside sites should not be routed through here.

First problem is that I'm not a Linux Guru in this area.

Second problem is that with two physical adapters, OpenSUSE 10.2 seems only able to run one at a time.

Third problem, pending resolution of the Second, is actually getting OpenSUSE 10.2 to work the way we want it.

UPDATE: Here is the way we actually want this to work:

eth0 - (externally-facing adapter)
Static IP: 192.168.20.5
Default Gateway: 192.168.20.1

eth1 - (internally-facing adapter)
Static IP: 192.168.10.5
Default Gateway: should be null
Routing information:
    Destination: 192.168.10.0
    Gateway: 192.168.10.5
    Netmask: 255.255.255.0

This works fine in CentOS. We are able to access the CentOS box using the internal IP address, and it is also exposed outside on the 20. The CentOS box can also access both internal and external resources via IP and domain name. That said I realize that given my limited knowledge of Linux this may not be the best approach.

We have been able to get CentOS 5.3 working (an altogether wonderful OS, by the way). However, the GUI in OpenSUSE is not only completely different, it's also more complicated and confusing.

ANY help would be appreciated!

share|improve this question

3 Answers 3

You might want to see if you can use a version of openSUSE that is still supported. The other thing you could do is to use ifconfig -a to check the status of your network interfaces. You could also look in /etc/sysconfig/network where SuSE stores in network configuration (at least, that's the way it is in 11.0).

share|improve this answer
    
We are required to use this version by our client. We can't change that. I already know how to check the status of the interfaces. That is how I know they are not working. –  Joshua Dec 1 '09 at 16:00
    
What is the output of ifconfig -a? Do the /etc/sysconfig/network/ifcfg-* files contain anything interesting? Maybe you could compare the configuration of the working interface to the non-working one. –  molecularbear Dec 1 '09 at 23:03
    
Nothing really interesting or weird. Obviously they look quite a bit different from say Ubuntu or CentOS. Both work -- it's just that only one can be enabled at a time. I think what Josh Budde is suggesting might work -- going to give it a try. –  Joshua Dec 2 '09 at 15:31

You need to go into Yast and under Network Setup change the config so its not Network Manager. You'll want to switch it to the option that says (Traditional) next to it. I have to do this on all our SuSE boxes as they are dual homed.

share|improve this answer
    
Ok still no luck. I've updated my original post with the different configurations I'm trying to do -- could you please look at that and tell me how I'm doing it wrong? –  Joshua Dec 2 '09 at 15:47
    
Some additional clarification: I tried with the traditional method, and it reacts the same way the other method is reacting. Routing and Gateway changes to one adapter also affect the other. What am I doing wrong? They need to be configured independently. –  Joshua Dec 2 '09 at 15:59
    
Ok so we have a misunderstanding of how Linux networking works here. In Linux there is 1 default gateway for the system. This should probably be your your external IP's gateway. You then define a route in the Routing area of network setup instructing your computer to route all 192.168.10.255 traffic to 192.168.10.5 –  Josh Budde Dec 2 '09 at 19:17
    
PROBLEM SOLVED. This was a misunderstanding to be certain, however unrelated to my routing configuration! The fact is, when I switched from DHCP to static IP addresses, apparently I also need to add at least a primary DNS in the hosts / domain area. I used the new public Google DNS (8.8.8.8) and now everything is working as it should. I appreciate your responses! –  Joshua Dec 3 '09 at 17:53
up vote 0 down vote accepted

PROBLEM SOLVED. This was a misunderstanding to be certain, however unrelated to my routing configuration! The fact is, when I switched from DHCP to static IP addresses, apparently I also need to add at least a primary DNS in the hosts / domain area. I used the new public Google DNS (8.8.8.8) and now everything is working as it should.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.