Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am trying to (temporarily) lower smtpd_policy_service_max_idle on postfix 2.3.8 from 300s to 5s to debug a possible client-side problem. The following seem to state that my change is accepted, but when I purposely leave the client idly connected for >> 5 seconds I don't see a timeout disconnect message in mail.log that I used to see when the value was 300s.

sudo postconf -ve smtpd_policy_service_max_idle=5s; sudo postconf | grep _idle
ipc_idle = 100s
max_idle = 100s
smtpd_policy_service_max_idle = 5s

Do I need to restart postfix to for the setting to take effect? Is there another timeout value that provides a (higher) lower bound?

thanks -nikita

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Yes, config settings in main.cf don't take effect until you restart (or at least tell Postfix to reload the config).

share|improve this answer
    
Yep, I issued exactly the commands cited in my original post and now see the following in main.cf: 'smtpd_policy_service_max_idle = 5s'. However, even after doing 'postfix reload' and 'postfix stop; postfix start' the idle timeout observed in testing is still 300s. How do I debug this? Is there another setting that overrides 'smtpd_policy_service_max_idle'? –  Nikita Dec 1 '09 at 18:14

Turns out I was twiddling the wrong param - smtpd_timeout turned out to be the right one.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.