Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a couple of vm's running on windows server 2008 and since they are set up to build work project at 3am it seems the memory they use is getting paged to disk and taking for ever to start up when i log back into them. Is there any way to stop the os paging vmware?

share|improve this question

2 Answers 2

First take a look at my answer here. Also since you said they were building it might be that they are experiencing the condition here

If neither of these article help there are some other last resort things you can try:

  1. remove the guests page file ( note that that action might make them run out of memory)
  2. increase the reserve on the host
  3. lastly you could delete the hosts page file. I would do this as a last resort as if it really pagefaults that much it's likely you are using up more ram than you physically have, in which case you would run out of memory.
share|improve this answer
    
Telling VMware to use only physical memory for VMs (as the OP discovered on his own) was the first thing to do here. –  Massimo Jul 20 '11 at 7:44
    
@Massimo - can you tell us where this elusive setting is please? –  Lewis Jul 20 '11 at 8:07
    
In VMware Server's host settings. It's not elusive at all, actually... –  Massimo Jul 20 '11 at 9:50
    
@massimo, yes that solves the problem but I still wonder why vmware is dropping pages from ram. Typically applications shouldn't deallocate pages the kernel does that - or am I missing something?. –  Jim B Jul 21 '11 at 12:51
    
@Jim: who said it was VMware paging them? It just chooses wheter to allocate the pages as swappable or locked in memory, then it's the O.S. which eventually swaps them if it needs to. –  Massimo Jul 21 '11 at 13:24
up vote 2 down vote accepted

There is an option in settings (memory) that allows you to select how vm workstation swaps ram to page file. After disabling this the vm's became so much more responsive.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.