Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

How do I disable X Window system on Fedora 11 box from startup at boot time ? Since host is used as a server and not as a desktop I'd like not to waste limited memory resources on X and Gnome.

share|improve this question

2 Answers 2

Remove an init script symlink from '/etc/rc?.d/': it should be called 'S*-gdm'. You can also rename it from 'S*' to 'K*'. The '?' sign stands for a runlevel.

share|improve this answer

The /etc/inittab file describes which processes are started at bootup and during normal operation. This file is used to start X windows system at boot by setting default run level to 5. Edit the file /etc/inittab using a text editor such as vi, enter:

vi /etc/inittab

Find line:

id:5:initdefault:

Replace with:

id:3:initdefault:

Save and close the file. Restart the server.

You can also drop to text mode by typing init command:

init 3

You should then be able to still run the command (if you need X)

startx

Hope that helps

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.