Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

On my home network, connected by means of a LinkSYS WCG200 Wireless-G Cable Gateway and a Unicom switch I have several computers.

One of these is an XP Home machine that I can ping by IP but not by name. Also from this machine I can ping other computers on the network by IP but not by name. This is the problem that I'm trying to fix.

All other computers on the network can ping each other by both name and IP. I've compared the settings on the TCP/IP connection for the problem machine to that of other similar XP machines and it all seems to be good and configured the same way.

Ideas?

share|improve this question

closed as off topic by Iain Sep 29 '12 at 7:51

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
When you ping the machine by name, do you get back the IP that the machine is supposed to have? Is any firewall blocking DNS on that machine? –  Ivan May 16 '09 at 19:58
    
No, when pinging the machine by name I get "could not find host xxxxx" –  Guy May 16 '09 at 20:02
1  
Is your Unicom switch really a switch or a router? Because if it has a DNS server then you can add the machine's name there. If not, you can add that machine to the hosts file of all the other machines... not pretty, I know... I'm sure this has something to do with NetBIOS, so I hope somebody else can help you find a true solution. –  Ivan May 16 '09 at 23:32
    
The Unicom switch really is a switch as far as I know. At one point the "broken" computer was connected through the switch but in order to take the switch out of the equation I have connected it directly to the router to try and solve this. Changing the connection from the switch to the router made no change. –  Guy May 16 '09 at 23:38
1  
A lot of these answers are close, but not quite right... Ping uses the DNS name to resolve, not the NetBIOS name... you need to add entries in whatever service or device is providing your DNS names. If you don't have a DNS server running, you'll probably need to set up a basic one. This MS KB should give a bit more info: support.microsoft.com/kb/305553 –  gharper May 17 '09 at 15:49
show 3 more comments

9 Answers

up vote 3 down vote accepted

Microsoft have a troubleshooting guide that might help. The other related pages contain a lot of information that might help diagnose the problem. http://technet.microsoft.com/en-us/library/cc940110.aspx

Something else you could try is the browstat.exe utility from Microsoft. That'll tell you which machines your PCs consider to be the master browser. I'm guessing the problem PC will have a different master browser to the rest.

You mentioned above that your machines are all set to static IP addresses. Another idea might be trying setting them to dynamic, that way it should eliminate the chance that there is one setting that is slightly off on the problem PC.

share|improve this answer
    
Although this hasn't completely fix the problem it's resolved it enough for me to continue to use this computer for what I was trying to use it for. I've described how I used your ideas here bit.ly/sOUud and will continue trying to completely fix this using the MS resources that you pointed me at - thanks! –  Guy May 17 '09 at 6:37
add comment

Sounds like you don't have the DNS Client Service running...?

JFV

share|improve this answer
    
How do I check that this is running? –  Guy May 16 '09 at 20:02
1  
Go to Control Panel --> Administrative Tools and double-click on 'Services'. Once in there scroll down to 'DNS Client' and see if it is running. If not, right-click on it and select 'Start' –  JFV May 16 '09 at 20:21
    
It was already running - thanks for the idea. –  Guy May 16 '09 at 20:31
add comment

Sounds like the firewall on that XP machine is blocking the ability to use NetBIOS based computer browsing or the Computer Browser service is stopped.

share|improve this answer
    
I've tried disabling the firewall and also switched off the anti-virus but still no luck - thanks for the suggestion. –  Guy May 16 '09 at 20:13
1  
When you browse the network through My Network Places >> The Entire Network >> Microsoft Windows Network do you see anything? –  K. Brian Kelley May 16 '09 at 20:17
    
When I do that from the broken machine (under Windows Network > Workgroup) it only shows the broken machine's name. If I do that from any other computer then it shows all of the machines on the network including the broken machine. If I then click on the broken machine's name (from a working machine) it says "the network path was not found" –  Guy May 16 '09 at 20:35
1  
WHen you look at the properties for that network connection, are the Client for Microsoft Networks and File and Print Sharing for Microsoft Networks both checked? –  K. Brian Kelley May 16 '09 at 20:57
    
Yes they are both checked. I also found a service called "Service Advertising Protocol" which I just installed and that's checked but it hasn't helped. Thanks again. –  Guy May 16 '09 at 23:33
add comment

Check the workgroup name on the XP box in question -- make sure it's the same as the other machines. Also, in the advanced network configuration, make sure netbios over TCP is enabled on the WINS tab.

share|improve this answer
    
The NetBIOS setting is set to default. The other two options are Enable and Disable. I have tried setting it to Enable before but this didn't help. The workgroup name on all the machines is the same. (It wasn't before I started this exercise but I had standardized the names of all the workgroup names on all machines before I asked the question here.) Good idea though - thanks. –  Guy May 16 '09 at 20:16
add comment

I suppose your LinkSys router works as your DNS server and DHCP server? It means that it translates names into IP addresses and provides IP addresses to client machine which you connect to your network.

Check your router web interface for connected devices. See, if the PC is in the list with its name or if an unknown device with the IP address of that PC is listed (Status / 'Local Network' / 'DHCP Client Table'). Is the name somehow "special", so it can't be registered on the LinkSys router? Just a guess.

share|improve this answer
    
No I've setup fixed IP addresses on each machine. When I look at the DHCP Client Table then there are only a couple of devices listed in there and those I believe are devices (such as the Wii) that have not been configured with fixed IP addresses. The 'DHCP Client Table' only shows MAC addresses, IP's, Duration and Expiration. –  Guy May 16 '09 at 20:44
add comment

Just another idea: in order to "hide" PCs in the network, there is a registry setting

 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
        "Hidden"="1"

Perhaps this option is set on that specific machine?

share|improve this answer
    
I checked and Hidden is not defined under Parameters. Thanks –  Guy May 16 '09 at 23:36
add comment

Add the internal IP of your router as a WINS server in your workstation TCP/IP settings.

Start -> Settings -> Control Panel Double click "Network Settings" Double click "Local Area Connection" Choose "Properties" Double click "Internet Protocol Version 4" Click "Advanced" Choose the "WINS" tab. Click "Add", add the IP of your router, click OK OK OK etc etc until the windows close.

share|improve this answer
    
How do you do that? –  Guy May 17 '09 at 20:07
add comment

You could also install Bonjour (not sure where you can find just that, but it is installed with iTunes, Safari and probably with Quicktime too), after that, you can resolve IPs for your computers by querying computername.local. So you could just do:

ping somecomputer.local

And it should just work. It is quite handy in mixed environments when you have Macs, Windows and Linux machines in the same home network.

share|improve this answer
add comment

I found the answer to this on my linux VM. one of them out of 10 or so was not mounting the CIFS (windows share). Turns out WINS Client was not installed.

http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/sag_tcpip_pro_usewinsconfig.mspx?mfr=true

Please up vote so other can find the solution as I know this to be correct.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.