Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have following configuration in .ssh config:

Host *                 
    GSSAPIAuthentication no
    Compression yes        
    ForwardAgent yes       
    ForwardX11 no          
    Protocol 2             
    StrictHostKeyChecking no
    NoHostAuthenticationForLocalhost yes
    ControlPath ~/.ssh/sockets/%r-%h-%p 
    ControlMaster auto                  

Host test
    User xxx
    Hostname some_ip

Of course I have more than 1 Host defined.

Now. When I connect anywhere I ger connection multiplexer which works great. But. When I connect to 2 specific hosts, both running Redhat, which I think can have something to do with the problem, I have following situation:

  • if I start 2nd connection to test host quickly, (I.e. ssh test on 1 konsole tab, and quicjly another in 2nd tab - it works ok. both connections go via multiplexed channel)
  • if I start master, then wait over 1 minute or so, and then try to start 2nd connection - master is disconnected, and 2nd connection also errors-out before connect.

What could be wrong?

share|improve this question
    
Nice, an OpenSSH feature I hadn't spotted before! Unfortunately I can't reproduce the issue, though - works fine here :) Does the -v flag of ssh give any more information? –  SimonJ Dec 1 '09 at 23:39
    
Unfortunately no - even -vv doesn't provide any significant clues. –  user13185 Dec 2 '09 at 12:42
    
Which version of openssh is installed on this 2 RedHat server ? –  Julien Dec 2 '09 at 14:33
    
SSH-2.0-OpenSSH_4.3 –  user13185 Dec 2 '09 at 15:42
    
Try using strace to monitor the original ssh process (the one supporting the multiplexed connection) while you start the second session. Your description smells like something is crashing. –  Kenster Dec 2 '09 at 19:52

2 Answers 2

Openssh-4.3 is pretty old and lots of multiplexing bugs have been fixed since then. You will probably have much better luck with a recent version. openssh-5.3 is the current release and 5.4 is expected to be out fairly early next year.

share|improve this answer

Might it be that the sshd_config on the redhat boxes has the ClientAliveInterval set to 0, or a similar issue? Seems to me that there's no keepalive packet sent, either from the server or (less likely, since it works somewhere else) from the client.

Do you have the same behaviour when you connect to other, non-redhat hosts?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.