Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Sometime over the Thanksgiving holiday, my Netbackup installation decided that it no longer liked the tapes in my library. It had worked fine a week ago with no changes that I can think of, besides moving the new week's set of tapes into the NetBackup pool. (I had previously moved them to an unused pool so that they wouldn't be written to until Friday.)

Now when I try to perform a backup, it immediately errors out with error code 96: "EMM status: No media is available unable to allocate new media for backup, storage unit has none available". If I try to label a tape, I immediately get error 98: "error requesting media (tpreq)". However, catalog backups work fine. (That is a different pool, though.)

The tapes show up in the output of nbemmcmd -listmedia ... with the correct pool and other information.

I have tried moving tapes into the Scratch pool and seeing if it would pull them into the NetBackup pool. I have verified that my policies are referencing the NetBackup pool. I have tried setting policies to a different pool and then setting them back. I've tried moving both tapes and a policy to a different pool. I've rebooted the Netbackup server and the tape library. None of it makes any difference.

I don't honestly know where to look next. If someone can suggest logs that I can look at or enable, I'd appreciate it.

It's Netbackup 6.0MP7 under Windows Server 2003.

share|improve this question

2 Answers 2

to complete wfaulk,

vmquery -m display a bunch of informations including the eventual expiration date, I use this command against the media in a pool when I got the infamous Error 96.

--------- snip!!!---
    created:               Tue Feb 10 10:39:50 2009
    assigned:              ---
    last mounted:          Fri May  8 00:11:01 2009
    first mount:           Fri Apr 17 11:07:51 2009
    expiration date:       ---
    number of mounts:      14
    max mounts allowed:    ---
share|improve this answer
up vote 0 down vote accepted

Turns out that an earlier attempt to set the expiration date of the data on the tapes accidentally set the volume expiration date, so all of those tapes were expired. Resetting the volume expiration to nil solved the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.