Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have this wierd issue with my DNS. If I assign a static ip to my machines (laptop or desktop) I am unable to resolve local servers, PCs, devices etc. via DNS even using NSLOOKUP (e.g nslookup server01) I get the error

*** nypdc.us.mycompany.local can't find server01: Server failed

but if I allow the machines to take IP addresses via DHCP everything works fine.

Any ideas where to look? I even tried manually puting the INTERNAL DNS IP from PDC.

Edit ~ I am also able to access the internet so the DNS is working for external items.

Thanks

share|improve this question
    
Are the DNS servers assigned by DHCP options different than the one you set statically? –  MDMarra Dec 2 '09 at 2:26
    
I presume Windows Server DNS and DHCP .. otherwise please update the question. –  tomjedrz Dec 2 '09 at 2:26
    
@MarkM - They are the same internal DNS servers. –  Saif Khan Dec 2 '09 at 2:31

1 Answer 1

up vote 1 down vote accepted

Your DHCP server is probably also handing out your domain's DNS suffix. Can you do nslookup server01.us.mycompany.local (or server01.mycompany.local not sure of your dns setup)?

If you do an ipconfig /all you'll see an entry labeled "Primary DNS Suffix" while you have a DHCP address to see what it should be set to. Alternately you can go to your TCP/IP properties and click "advanced" then go to the DNS tab, it will show you what your DNS suffixes should be if you do that while you have an IP via DHCP, then you can replicate those setting manually when you give yourself a static IP.

share|improve this answer
    
you are correct. I tried palyin with this earlier but didn't see any settings in the DNS prop. Will try again. –  Saif Khan Dec 2 '09 at 2:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.