Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I SSH into a unix server using SSH client version 3.2.9. Several key features do not work when i'm logged into the server. to name few: backspace (^H is made instead but shift+backspace works), when i press <tab> I do not get suggestions, ~ does not take me to home.

I have local.cshrc, local.login and local.profile in my home folder (when I login).

Following is in local.profile

$ more local.profile
# Copyright (c) 2001 by Sun Microsystems, Inc.
# All rights reserved.
# ident "@(#)local.profile      1.10    01/06/23 SMI"
stty istrip

export PATH
share|improve this question
What do you see when you enter echo $TERM when you're on the server? – Dennis Williamson Dec 2 '09 at 6:42
I get vt100 This_is_for_limit – Omnipresent Dec 2 '09 at 20:25

4 Answers 4

A quick fix is to do:

stty erase <backspace>

Where, you try to hit backspace. Hit enter at the end of that line, and from that point on, the system will recognize that as your backspace character -- but it will only stick for the length of that session.

It's a temporary fix, for when you can't be bothered with logging out, changing the terminal type, and logging back in.

share|improve this answer

Typically this is caused by your terminal not being recognized on the remote end. If you are connecting to an old Unix or Linux system you may need to change your terminal type to be vt100.

share|improve this answer
I had the same problem and this solved it (for now I tried ssh from a plain xterm, vs. my regular urxvt, and backspace worked fine from there) – Dalker Jun 15 '13 at 16:12

I don't know about "SSH Client 3.2.9", but most SSH clients let you specify whether your backspace key will send ^H (backspace) or ^? (DEL). Your problem is that you're using the latter when you should be using the former.

In Putty, you change this for a saved profile under the profile's keyboard options. Look for a similar configuration option in your client, or switch to Putty.

The suggestion from @oo. regarging stty erase <backspace> will tell your terminal session to expect whatever character your SSH client is sending. Fixing this in your client is a better solution.

Note that in the stty command, you MAY have to prepend the backspace key with a Ctrl-V to "escape" it so that it's dealt with literally. Modern shells (bash/tcsh) will often "accept" a DEL even when Backspace is the erase character, just to make things easier for people.

share|improve this answer

Permanent Fix: I have seen such problems before.

Take the backspace for example, the remote host expects some character to be used as "erase/backspace" , while you pressing backspace in the terminal , the terminal program will send some character to the remote host, if what the remote host expects diffs with the characters sent by the terminal program, you would encounter this issue. So a quick fix is as below:

run command #stty -a in the remote host, and find what is expected to be an erase code in the output. Say erase=^?. In the terminal, type Ctrl v and press your backspace. You'll see what code is sent as "erase". Say it is ^H. In the remote host, run #stty erase ^H. You can fix the Tab issue with the same as above.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.