Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I followed the instructions listed here:http://www.mydigitallife.info/2007/09/18/turn-off-and-disable-search-indexing-service-in-windows-xp/ to free up space on hard drive by deleting the windows.edb indexing file...

I also stopped windows search service as mentioned in the comments following the article. In addition to unchecking the "Allow Indexing Service to index this disk for fast file searching" check box on the properties dialog for the C:\ drive, I did the same for two usb connected hard drives (J:\ and I:\ ). I'm not sure why I did that, thought it might shrink the windows.edb file so I wouldn't have to delete it (which sounded a bit risky in my ears at the time). The file of course didn't shrink so I ended up deleting it and freeing up over 3 GB of space, yeehaw.

However, as soon as I had done this I could not access the usb connected hard drives anymore. The error I got was "I:\photos is not accessible" "The file or directory is corrupted and unreadable" when I tried to open the photos directory on I:\

Here is where I enter the twilight zone... I try disconnecting I:\ usb hard drive. But XP shows me that instead J:\ drive has disconnected and I:\ is still there. So I disconnect both drives and restart the computer. I then connect one drive, but it lists up the contents of the other drive on root level. I tried connecting the drives vice versa and the same thing happens. I try taking one of the hard drives to another computer and when I connect it there it lists up not its own contents but the contents of the other hard drive and gives the same error as above when I try and access any of the folders (even folders on the root that have the same name as folders on the other drive (e.g. J:\photos and I:\photos)???

And no, this is not a me mixing up my drive letters. Computer Manager -> Disk management shows the same result as explorer: The drive size is correct (one is 500GB, the other is 640GB) but the drive name is of the opposite drive, as long as the contents. Also, one drive was full of data and the other almost empty but they incorrectly show their free space status of the other drive.

Somehow the usb drives seem to have switched file tables, file records, boot records or something, extremely weird!

Even weirder, if I try and create a text file or folder on this drive, it works fine, accessing them, saving, whatever, all good, but accessing any other data on the drive gives me an error.

Does anyone have a clue what is going on and more importantly, how I can restore the correct folder listings to access my family photos ???

cheers, linni

share|improve this question
belongs on superuser? –  rodjek Dec 2 '09 at 5:49
Thank you, I posted this on superuser as well... didn't know it existed :) However, I feel the crowd here might be better in spotting the solution as it probably has to do with some sort of rebuilding of the $MFT - master file table, partition table or something of that nature. Also - if win xp is overwriting e.g. $mft data on external drives with false data under certain circumstances I would like to put the warning out there to as many people as possible... –  linni Dec 2 '09 at 8:32

1 Answer 1

What happens if you plug those two external drives into another computer? (that will narrow down whether the problem exists with the drives, or with the installation of Windows that you deleted the file from)

Deleting Windows files is not a good idea (as you have found). Weird random things happen :).

That said, I cannot think of any reason why deleting the Windows Search index should be causing the problem you describe. If the solution involves rebuilding the MFT, you are going to be better off backing up, reinstalling Windows, and reloading everything. I don't know of any easy way to play with the MFT or partition table. That is too low-level for an end user to do anything with.

For future reference, you should be able to shrink the Index file (windows.edb) by rebuilding it. If the index file is still large, you can move it to another location (such as your D:\ drive). Both can be performed under Control Panel > Index Options, and clicking on Advanced.

share|improve this answer
Thanks for the reply Sean. Well as I mentioned in the post (amongst a flurry of other words). I did try connecting the hard drives to another computer. Same problem there. So as you rightfully point out; the problem narrowed down to the drives. The MFT on the external drives seem to have changed, the MFT on the C:\ (system drive) on the computer is fine and needs no rebuilding. My concern is, how can I access the data (my family photos) on the external drives in order to back them up before restoring the MFT on the drives if I cannot access it because of a broken MFT ? Catch 22 anyone ? –  linni Dec 3 '09 at 2:57
Ouch :( Sorry to hear that! I think you are right about the MFT being corrupted. I would say your best bet would probably be to run one of the "Deleted picture recovery" utilities on the internet... they scan the drive for pictures without referring to the MFT (since they would be missing from the MFT if they were deleted, even if they were not actually overwritten by the filesystem). I don't have any specific suggestions for a good one, and it looks like most of the utilities listed in a quick search cost something. Hopefully someone will have a recommendation for a good one to try. –  Sean Earp Dec 4 '09 at 5:02

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.