Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

In Windows XP, it's possible to use the at command to launch programs (e.g. "at 5:00PM /interactive gohomefromwork.exe"). The at command also exists in Windows Server 2003 but I can't seem to run programs interactively there.

Instead, with a command of "at 5:00PM /interactive notepad.exe", notepad.exe is launched with no visible window at 5PM.

How can I get the /interactive flag to make at run the program...interactively?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

I'm getting CMD.EXE and NOTEPAD.EXE to start fine w/ the /INTERACTIVE switch on Windows Server 2003 Standard 32-bit Service Pack 2.

I suspect you're connected to a non-console session with Terminal Services. The programs started by Scheduled Tasks from an AT w/ the /INTERACTIVE switch will show up in session 0, which is visible only on the console (or a Terminal Services session connected to the console session).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.