Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've had Windows 7 Ultimate 32 bit installed on my desktop for a week or so now, and there's one pretty big issue for me. My home network has a Centos 5.3 file server running Samba 3.0.33. Right next to it, hooked to the same switch, I've got a W2K server. So I get file transfer speeds from the W2K box to the W7 box around 1.5MB/s, while access to the Centos Box only gets 250KB/s. It's not just via Samba, either - ftp exhibits the same problem. I've tried a new NIC in the W7 box. I've tried putting the W7 hostname in the /etc/hosts file on the Centos box. I've swapped cables from the switch to the servers. None of these had any noticeable effect. Any ideas on what else to check? If I were paranoid I'd think Microsoft was sabotaging connectivity with Linux ;-) One more thing: before installing W7, I had an XP Pro install that worked perfectly fine. I really don't think it's hardware at this point.

share|improve this question
    
What hardware is on the boxes and what is your networking hardware? All of those speeds are atrocious. Since I installed Windows 7 (x64) I can get near wirespeed gigabit transfers over samba to and from my Slackware 12.2 box. It's not uncommon at all for me for network file transfers to go over 100 MB/s, and yes I mean bytes not bits. –  Matt Dec 3 '09 at 5:42
    
The Centos server is a Dell Poweredge T10S. W2k is an older eMachines T2245. The W7 box is a generic AMD Athlon 64 X2 4200+. Network gear is all Linksys. I realize the eclectic collection of hardware isn't going to win any speed races, but it works for home. All I want is equivalent performance between the boxes. I've also realized it's MB/s and KB/s as edited. –  DCookie Dec 3 '09 at 6:01
add comment

2 Answers

up vote 1 down vote accepted

Try swapping out the switch. Hopefully you can just borrow one from a friend temporarily. Those speeds are still completely atrocious, even the 1.5 MB/s. How fast was it when you had XP Pro installed and it worked "perfectly fine" ? Even if your switch is only 100 megabits you should still get 8-10 MB/s file transfers over SAMBA, maybe even a bit closer to the theoretical max of 12.5 MB/s. You haven't explicitly said so, but I gather from what you've written so far that no possible combination of your 3 boxes yields transfers faster than about 1.5 MB/s. If this is true, this is why I think the problem is something in common between them, which would be the switch. The other thing I just thought of is maybe your switch is really old and it's only a 10 megabit switch? If that's the case do yourself a favor and spend the $10 to get a 100 mbps switch, or even a gigabit one. They're just not very expensive anymore.

share|improve this answer
    
I don't see how that could be the problem. I have physically unplugged the cables at each server and swapped them with no effect. In other words, the cable and switch port have no effect on the outcome. The W2K server is 6x faster every time. –  DCookie Dec 5 '09 at 16:55
    
The net is mostly 100megabit equipment, with one 10megabit switch I use on the rare occasions when I bring home a non-wireless capable laptop from work. –  DCookie Dec 5 '09 at 16:59
    
Truthfully, I don't know how fast it was with my old XP system, I just know it worked well enough not to make me notice it. I do agree, there is something wrong between them, but I suspect some net config issue. –  DCookie Dec 5 '09 at 17:02
    
I'm with Matt on this one. If the maximal speed you get in any combination is 1.5 MB/s, then this is a hardware issue. Unless, of course, you have manually set network adapter speeds to 10 MBPS. Check that, really! (on Linux, use ethtool to see configured link speed) –  chronos Dec 7 '09 at 8:50
    
Please explain to me how a hardware problem with a switch is dependent on the server. I truly don't get that. Ignore for a moment the second switch port, and assume I plug port 1 into the W2K server and get 1.5MB/s. I unplug the network from the back of the server and plug it into the CentOS server and get 250KB/s. How can that be hardware? I would believe it if the results were consistent. –  DCookie Dec 8 '09 at 21:17
show 3 more comments

Matt was right. It was the switch. Here's what I found out:

I decided to take a step back because I was kinda flailing about. I downloaded pcattcp for my windows platforms and installed ttcp on my CentOS system. I then ran some tests and put them into a matrix (all numbers are KB/sec, and all hardware is 100mbps):

              W2K (sw)	CentOS (sw)	  W7	     XP
W2K (sw)         X	   10200	  909	   1391
CentOS (sw)  11400	       X	  265	    725
W7            7294	    7287 	    X	  10100
XP            6650	    7480	10291	      X

So, the first two boxes are on the switch in question, a Windows 2000 and a CentOS box. The XP box is on another switch while the Win7 box is plugged into the router. The boxes on the left are the senders of the data, across the top are the receivers. As you can see, and to my surprise, the results from boxes on the switch are horrid, while the situation to boxes on the switch, while not superb, are livable. The interesting part to me is the difference in speed depending on direction! Now that I have actual numbers though, I can see the problem must be on the port connected the switch to the rest of the network. So I swapped the cable to another port, and voila, the results become:

                W2K (sw)   CentOS (sw)	       W7	    XP
W2K (sw)            X	      10382	     6818	  9531
CentOS (sw)     11095             X	    11436  	 10560
W7               7957 	      11055	        X	 10195
XP               7281	      10835	     9351            X

Ahh, much better! While the speed still is not as fast as it should be via the switch in question, it's remarkably better. I'll be replacing the switch since it's clearly a problem child, but at least I know what's going on now.

The moral? Always Measure! I couldn't get a clear picture of what was actually happening without measuring and putting it in a form that was easy to read. The thing that was tripping me up in this case was the fact the problem was only manifested obviously in one direction (still weird to me).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.