Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Why is disk access on Windows Server 2008 3x slower than Windows Server 2003? We are purchasing new hardware for our build servers and may end up with a 6 year old OS because disk access is so slow with Windows Server 2008 and 2008R2. I have performed benchmark tests on clean OS installs on the exact same hardware. The benchmark consists simply of unzipping an 800MB zip file of source files. We use 64bit 7Zip to unzip. Uncompressed the source tree is approximately 3.9GB and consists of 43k files. We then delete the tree via "RD /q /s".

Benchmarks:
      Windows Server 2003    - 2:12
      Windows Server 2008    - 5:05
      Windows Server 2008 R2 - 6:15

I have tried the test with indexing disabled, but it did not help. Is there a configuration setting I have missed?

Write caching is not enabled. My device driver will not allow me to enable write caching. I get "The device does not allow its write-caching setting to be changed."

No shadows on the system:

C:\>vssadmin list shadows
vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool
(C) Copyright 2001-2005 Microsoft Corp.

No items found that satisfy the query.
share|improve this question
    
Do you have Shadow copiy service enabled for this volume? –  Sergey Dec 3 '09 at 14:32

4 Answers 4

Can you double-check that write/read cachning is enabled on the disk volume within device manager? Also, is it possible for you to breakdown those figures into portions of the test (most specifically: does it take several minutes longer to delete the files on 2008?)

share|improve this answer
1  
Yes, it seems the delete is where the problem is. –  Todd Kobus Dec 3 '09 at 16:38
    
That indicates a problem with cache, as it's probably hard-deleting the files (instead of just marking the space where they are stored to be free). Did you check the cache settings? –  pauska Dec 3 '09 at 18:10
    
I see that you updated your original question with write caching not enabled. This is probably why you are experiencing these problems. Consult your SAN vendor. –  pauska Dec 4 '09 at 10:32

Are these disks on RAID ?

Additionally is the pagefile.sys on the drive where you are testing the file copy and deletes ?

share|improve this answer
    
We have tried multiple configurations from SAS drives on a SAN connected by fiber to simply using the C: drive which is a RAID0 pair of SAS drives. Nothing could get the speed inline with that shown by Windows Server 2003. At no point did I change the page file location. –  Todd Kobus Dec 3 '09 at 6:34

Piggybacking off echobeach2's answer, maybe try turning off AntiVirus on access scanning and re-run the test for both platforms?

Maybe there's a key difference in speed due to your antivirus on access scanner between Server 2003 and Server 2008....

share|improve this answer

Since this is local, not network access, it is very unlikely to be the SMB2 problems. There is very slow performance when SMB1 clients talk to SMB2 servers and vice versa.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.