Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just purchased this box for home backups for my pc's and mac's. Everything works great accept for the remote access part. I can RD into the machine locally but I can't get to it from outside of my network. I've enabled port forwarding on my router but it doesn't seem to matter. I checked with Qwest and they don't block these ports so I'm at a loss.

I do have Vonage in front of my router but I've taken it out and it didn't make a difference. I suspect I've made an error with my router setup. I'm a programmer and I'm playing in the world of the unknown here. I'm lost. Any suggestions?

share|improve this question

closed as off topic by Zypher Jan 20 '12 at 17:55

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
What's the router model? –  splattne May 17 '09 at 14:35
    
I forgot to mention that when I turn logging on the router I see zero activity for that IP Address. I can't ping it either (outside my home network). –  Billy Coover May 17 '09 at 14:36

3 Answers 3

up vote 1 down vote accepted

Update:

This link explains how to troubleshoot Remote Access for your MediaSmart or Windows Home Server:

IMPORTANT - MUST READ: If you have any other routers on your network. This includes DSL or Cable modems with built-in routers, Vonage or other IP Phone devices this could be the cause of your trouble. You can try to set the DMZ from the Vonage or VOIP, DSL or Cable device to your router and then try the MS Router config again. This could solve your issue.

If you have a vonage router that is in FRONT of your normal router, you can try to move the vonage device behind the router. Make sure you reboot your cable modem, router and vonage device (in that order pausing 1 min before powering up each device). Make sure the MediaSmart server is connected to the normal router and not the vonage device (unless that’s your setup)


If you'll get an "Verifying that your remote web site is available from the internet" error on configuring your router, read this Microsoft forums thread:

I had the same problem which had kept me busy for two days. Just found the solution on the internet. First unconfigure both the router and domain. Then configure the domain first end the router afterwards.


Could it be the case that you're looking for the problem on the wrong end? Could it be that you aren't allowed to connect from your remote location?

If your router model is a UPnP-certified device and if the router UPnP setting is enabled, Windows Home Server can automatically configure it. See this Microsoft support article: Information about the automatic router configuration feature in Windows Home Server.

If the latter method doesn't work with your router model, try forwarding following ports that in order to enable remote access: TCP 80, 443 and 4125 to the local IP address of your Windows Home Server.

share|improve this answer
    
I can RD to other machines from my remote location. RD is less important to me at this point. Accessing the server from the internet it what I'm really trying to accomplish. It is a media server and it supports streaming of media content and I'm trying to get that working. –  Billy Coover May 17 '09 at 14:39
    
Linksys wrt54g - UPnP is enabled but I get an error when "Verifying that your remote web site is available from the internet". –  Billy Coover May 17 '09 at 14:50
    

Assuming you can remote desktop from the local machine, then Remote Desktop is working. Are you able to remote desktop to it from machines on the network?

RDP uses TCP port 3389, so make sure that is the port you have forwarded on the router, and that it is open on any firewall that is on the HP machine itself. Also, can you connect to any other services on that machine from outside the network? May be worth doing a portscan to make sure that everything is open

If that does not work it could be that something is blocking the RDP port somewhere. You can try chaning the port RDP listens on to see if this is the case, this article explains how to do so. When connecting, you then add :portnumber to the end of the IP in the remote desktop client.

share|improve this answer
    
I did a port scan and all ports come up a stealth. –  Billy Coover May 17 '09 at 14:40
    
Then thats your problem, the port is not correctly setup to forward to your server. What router do you have? –  Sam May 17 '09 at 14:44
    
see my post below - this is not how home server configures itself for remote access –  CPU_BUSY May 17 '09 at 14:46

The way to remote to your home server is through a web interface over ssl

Home server configures itself to only allow RDP connections from its own subnet. It does however create a proxy to allow rdp over SSL

In the home server console under settings - remote access you can have the home server configure your router and set the domainname - You can use a free subdomain of homeserver.com

Then check that the DNS name you use is resolving to the IP that your cable/dsl modem has

This has greater benefits over just being able to rdp - you can access the shares directly without rdp - you can even stream your own music/video with plugins

share|improve this answer
    
I think this is part of my problem. When I try to configure remote access I get an error that the remote web site is not available from the Internet. –  Billy Coover May 17 '09 at 14:47
    
well it will be if you went into the router afterwards and modified the port forwarding. The DNS takes up to 24 hours to propagate - even if you are using a homeserver subdomain. You need to verify with nslookup that that works before moving to the next step. Using RDP directly will conflict with these settings. –  CPU_BUSY May 17 '09 at 14:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.