Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

There was a post discussing VNC hanging when connecting to OS X a few months back, but it was OS X 10.4, so I thought I'd see if someone has experience with our problem.

We're trying to remotely connect to a Mac mini from Vista machines. The Mac is running Snow Leopard. We're doing this over the LAN - we don't want to go out over the Internet and back in - so we're using VNC.

We can connect OK, but, after about 5 mins, the connection drops and we're left with a static image of the screen prior to the connection having dropped. The VNC client appears to be active (e.g. screen repaints when you move windows on top of it, etc). Close the client and restarting it allows us to reconnect. However, five minutes later we're "frozen" again.

We've disabled sleep and switched off the screen saver.

We've tried UltraVNC and TightVNC - both have the same issue. I've read some similar comments about RealVNC (using Leopard/XP).

Does anyone know a way to fix this? We'd rather not have to use KVMs, and solutions like LogMeIn, even if they'd work better, seem to need to go via the Internet - which is not an option for us.

UPDATE

Seems like it's only that the screen is not getting updated. If we connect it to a physical monitor then the mouse/keyboard actions are still being performed.

share|improve this question
    
I have the exact same issue. It happens in both the linux and windows versions of Tight VNC. –  mattd Dec 4 '09 at 15:35
    
@stevec has it figured out. Disabling clipboard sharing fixes the bug –  The Lame Duck Sep 29 '10 at 15:18

3 Answers 3

up vote 1 down vote accepted

We had this problem with our Mac Mini which we have for support. The solution we found was to use Vine Server which is a free download, and supports Snow Leopard. There is a "System Server" option which allows it to run on startup, and when combined with UltraVNC on our Windows computers it seems to have been stable enough for general use. Although it seems to work alongside the Apple VNC server, you should turn that off to ensure no confusion.

share|improve this answer
    
That's working for me too! Just the ticket. Wonder what's up with the internal one? No matter - Vine's working great. –  dommer Dec 4 '09 at 23:19

We had awful issues with Vista's networking stack for realtime based traffic in the way it tries to 'tune' the interface.

This seemed to help, from cli on the windows box issue the following command: netsh int tcp set global autotuninglevel=disabled

It turns off all the Network 'Tuning' vista can do such as receive side scaling etc.

You can also see the current settings first using: netsh int tcp show global

share|improve this answer
    
Thanks. But I'm afraid that didn't solve it. Also, we're finding the same issue on XP. –  dommer Dec 4 '09 at 11:52

I get exactly the same behaviour.

The trigger is copying something to the clipboard on the Vista (ie client) machine. The default behaviour of VNC clients is to synchronise the clipboard between the host and server machines, so this is sending some kind of message to the Mac (server). I've reproduced this using TightVNC, UltraVNC and RealVNC on Vista and XP, which suggests that the problem is with the OSX vnc server somehow not being able to accept the 'synchronise clipboard' message.

When this happens, I am able to start another VNC client and reconnect immediately. The 'hung' session remains static, showing a copy of the Mac desktop from when I used the clipboard.

You can disable clipboard synchronisation when starting the VNC client, for example in RealVNC (4.1.3) it's under Options, Inputs, Send clipboard changes to server. This prevents the hangs, but obviously also prevents sharing of the clipboard.

share|improve this answer
    
This was broken using the clients noted above when I was connecting to a Leopard (10.5) machine. Since upgrading to Snow Leopard, I can confirm that RealVNC's vncviewer is allowing clipboard synchronisation with no hanging. –  stevec Dec 28 '11 at 14:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.