Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have put the shortcuts of virtual machines using vmrun in startup folder as batch file.

Now they are working correctly .

When i use remote desktop coonection to main or host OS(2008 server) using username and password . It is only then that that startup folder executes and my virtual machine starts othwise not

In the user account i have enabled the option where user don't need username and password to login.

What should i do

share|improve this question
up vote 3 down vote accepted

Because of the way workstation works, you need to login and have the account running before your VM's start.

If you keep your login running, then your workstations will always be running unless the server reboots or RDP inactivity session policies.

If you want your workstations to start when the server boots, look at running VMWare Server instead.

share|improve this answer

I may be misreading your question, but what about setting up the machines to automatically log-in when powered on.

I have done this using a reg file with something like this.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.