Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Hi this is quite and embarrassing question as I should really now how to do this.

I have php5 installed on ubuntu Jaunty server it looks to me like some of the modules come pre-compiled in the php package things like gettext, hash, etc any packages i have installed such as PDO and pdo_mysql i have no trouble removing but I wish to remove gettext from the server and for the life of me cannot find how.

On FreeBSD there is an extension.ini file that i can just comment out extensions and there gone and if there isn't an extensions file i should be able to comment them out of php.ini but neither of these options appear to be of any help to me on ubuntu.

Any help would be appreciated.

share|improve this question

migrated from Dec 4 '09 at 7:49

This question came from our site for professional and enthusiast programmers.

There is an extensions directory defined in /etc/php/php.ini and in that directory is the shared objects, so delete or move them somewhere else and they wont be loaded when apache loads the php module

Edit/Expansion: at the bottom of your php ini there should be an include /path/*.so with a comment along the lines of "load all shared objects" this confirms that your (slightly different from compiled) ubuntu version of php is loading extensions this way.

Good luck, let us know how you got on.

share|improve this answer

Have you tried disabling the said function(s) in php.ini ?


disable_functions =exec,passthru,shell_exec,system,proc_open,popen,curl_exec,curl_multi_exec,parse_ini_file,show_source

Have a look at this.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.