Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running windows 7 and using WAMP for my local development. Now I Installed Cultbooking ( in my wamp and can't finish my installation because it says sock "Socket support - Socket not supported". I don't know how I can enable my socket. I'm new to web development.

This is what I did, I download the Cultbooking from the ( and drag the files to my 'www' directory of my wamp. Now when i pointed my browser to my localhost it say

  PHP version >= 5.0 Yes

  zlib compression support Available

  XML support Available

  MySQL support Available

  Socket support Unavailable

  configuration.php Writeable

Now my only problem is my Socket support. How do I enable it? if you're in my shoes, Any Ideas?


share|improve this question

closed as off-topic by Hyppy, masegaloeh, Katherine Villyard, MadHatter, mdpc Apr 18 '15 at 5:55

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions on Server Fault must be about managing information technology systems in a business environment. Home and end-user computing questions may be asked on Super User, and questions about development, testing and development tools may be asked on Stack Overflow." – Hyppy, masegaloeh, Katherine Villyard, MadHatter, mdpc
If this question can be reworded to fit the rules in the help center, please edit the question.

up vote 1 down vote accepted

It looks like you've got a build of PHP installed that doesn't have sockets enabled. (Sockets are an abstraction that are used in code that makes and receives TCP/IP connections.)

It looks like this was supposed to be fixed in the official Windows binaries back in 2002. If you're not running an official build it might help to investigate that first. If the official builds aren't being compiled with "--enable-sockets" specified then you'll need to build it youself with the option enabled.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.