Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Note: I looked into ESXi, but it does not support my CPU.

I have encountered the following error on two machines:

  1. Ubuntu Desktop 9.10 32-bit version, hardware is a 64-bit AMD AthlonX2 CPU and 1 GB RAM
  2. Ubuntu Server 9.10 64-bit version, hardware is a 64-bit AMD Phenom CPU and 3 GB RAM

I started at the Ubuntu wiki, which led to this blog post with an installer shell script that applied VMWare's patches for the 2.6.31-14-server kernel.

After a couple hiccups, I got things installed and was able to sign into the web admin on port 8333.

Attempting to stop VMWare using

sudo /etc/init.d/vmware stop

saw a failure on the Virtual Network. Attempting to start it:

sudo /etc/init.d/vmware start VMware Server is installed, but it has not been (correctly) configured for the running kernel. To (re-)configure it, invoke the following command: /usr/bin/vmware-config.pl.

Running the configuration says:

sudo /usr/bin/vmware-config.pl The following VMware kernel modules have been found on your system that were not installed by the VMware Installer. Please remove them then run this installer again.

vmmon vmci vmnet

I.e. - 'rm /lib/modules/2.6.31-14-server/misc/.{o,ko}'

Execution aborted.

Following these instructions sometimes gives a working system, sometimes it take a couple tries. The server will work for a little bit, then throw the same error.

Has anyone got a stable VMWare Server setup on a Ubuntu Server 9.10 host? If so, how?

share|improve this question
    
No real solution, we ended up rolling back to an older kernel. –  hewhocutsdown Dec 19 '09 at 18:09

3 Answers 3

Is there any reason why you must run Ubuntu 9.10 as the VMWare Server host OS?

I have been reliably running VMWare Server (1 & 2) with Ubuntu Server 8.04LTS for years.

It is supported by VMWare and installation is a lot simpler. i.e. Install gcc and your kernel headers and you are good to go.

I have documented the few optimisations I put in place at the OS and VMWare level below. From experience I have found this results in more consistent performance across the VMs:

And here is a quick rundown on how to enable USB support on Ubuntu 8.04 with VMMWare Server 2:

p.s. I have setup hypervisors running Ubuntu 8.04 32bit and 64bit without any problems.

share|improve this answer
    
We ended up using VMWare Player on Ubuntu 8.04 64-bit in the end; haven't had a chance to test Radu's new script, hopefully in a week or two. Thanks for the resources. –  hewhocutsdown Feb 24 '10 at 13:11

Unfortunately no solution found yet and do have exactly the same issue.

It starts to look like these problems are showing up when:

  • Ubuntu 9.10
  • 64 Bit (hw/os?)
  • Vmware Server 2.0.2

My setup is 2.6.31-16-server #53-Ubuntu SMP Tue Dec 8 05:08:02 UTC 2009 x86_64 GNU/Linux, running on a quad core Xeon (IBM x3650).

share|improve this answer
    
This didn't work for me, but it seems to for others: radu.cotescu.com/2009/10/30/… –  hewhocutsdown Dec 28 '09 at 15:12

I've redesigned the script with a better patch and now VMware Server seems more stable. Please test it again. Also now I've added support for Fedora and openSUSE.

share|improve this answer
    
We'll give it a try, thank you. –  hewhocutsdown Jan 20 '10 at 14:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.