Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I just uninstalled WAMP on Windows 7 because I have been getting an error when I install an application (I think not compatible to WAMP's MySQL).

So I installed XAMPP on Windows 7 - I get no errors but when I point my server to localhost it just keeps loading with no response. XAMPP and the application are working fine on Windows XP.

Any ideas on what is wrong?

share|improve this question

closed as off-topic by masegaloeh, Katherine Villyard, Scott Pack, mdpc, Andrew Schulman Apr 23 at 7:12

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions should demonstrate reasonable business information technology management practices. Questions that relate to unsupported hardware or software platforms or unmaintained environments may not be suitable for Server Fault - see the help center." – masegaloeh, Katherine Villyard, Scott Pack, mdpc, Andrew Schulman
If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

up vote 1 down vote accepted

This thread suggests that Windows 7 runs it's own process on port 80 which will conflict with Apache. The suggested solution is to install Apache as a service and then restart. Alternately, you can disable http.sys. You can shut it down from the command line with net stop http. This page has a permanent solution:

  1. Start regedit (Start -> Run -> Type "regedit")
  2. Go to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP
  3. Add a new DWORD (32-bit) value
  4. Name it ‘NoRun’ not including the quotes
  5. Double click the new property
  6. In the Value data field type ‘1′ not including quotes and click OK
  7. Re-boot your computer
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.