Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Is it possible to get PHP5.2.3 for debian etch?

I got 5.2.0-8+etch13

share|improve this question
    
Any particular reason why you want 5.2.3 specifically? –  andol Dec 5 '09 at 16:52
    
Yes. I want to run Kohana framework. It is a requirement (kohanaphp.com) –  Cudos Dec 5 '09 at 16:58
    
Seems as if the Kohana Requirements page say "PHP version >= 5.2.3". That is, you need 5.2.3, or newer. –  andol Dec 5 '09 at 17:04
    
Correct, I need 5.2.3 or newer. –  Cudos Dec 5 '09 at 17:16
add comment

2 Answers 2

up vote 3 down vote accepted

Not directly from official Debian repositories but you can 'backport' newer PHP packages yourself if really needed.

It requires a few development packages, a few packaging knowledge and time.

Some people already did

share|improve this answer
add comment

Yes. Change your apt sources to fetch from unstable.

share|improve this answer
    
Actually, Debian unstable currently has PHP 5.2.11. The same goes for testing (squeeze). –  andol Dec 5 '09 at 16:54
    
Ok, based on new info, never mind I guess. –  andol Dec 5 '09 at 17:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.