Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I got this issue on an FC8 server where if I search for something in yum, it finds the packages I am searching for but then when I go to install the package it says its not there...?

[hamstar@tankian ~]$ yum search pecl
php-pecl-apc.i386 : APC caches and optimizes PHP intermediate code

[hamstar@tankian ~]$ sudo yum install php-pecl-apc.i386
Setting up Install Process
Parsing package install arguments
No package php-pecl-apc.i386 available.
Nothing to do

[hamstar@tankian ~]$ sudo yum install php-pecl-apc
Setting up Install Process
Parsing package install arguments
No package php-pecl-apc available.
Nothing to do

wtf?

EDIT: Yum update shows this:

[hamstar@tankian ~]$ sudo yum update
Setting up Update Process
No Packages marked for Update

EDIT: I also tried this and tried it all again with no luck:

[hamstar@tankian ~]$ sudo yum clean all
Cleaning up Everything

EDIT: So i just realized this package is installed, but replacing the package name for pyqt (and variations of) which is not installed gives the same results. Here is the output for a package that is already installed on my other FC8 server.

[root@dolmayan ~]# yum install php
Setting up Install Process
Parsing package install arguments
Package php - 5.2.4-3.i386 is already installed.
Nothing to do

RESOLUTION
In Alex's comment down there he said go to this fedora wiki page so I did and followed the commands:

wget http://kojipkgs.fedoraproject.org/packages/fedora-release/8/6.transition/data/signed/4f2a6fd2/noarch/fedora-release-8-6.transition.noarch.rpm
su -c 'rpm -Uvh fedora-release-8-6.transition.noarch.rpm'

Got the key from here emptied the old gpg key and pasted the new one into it.

su -c 'echo > /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-8-and-9
sudo vi /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-8-and-9

Then I ran:

su -c 'rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-8-and-9'

Done!

share|improve this question
    
The actual problem isn't search vs. install, but "running as user" vs. "running as root". As they can have different caches. You can also run with "yum search -v blah" to get a lot more info. (like the repository the package is in). –  James Antill Dec 22 '09 at 22:19

4 Answers 4

up vote 3 down vote accepted

I would start with:

sudo yum clean all

and then try

sudo yum -y install php-pecl-apc
share|improve this answer
    
No luck with this either :( –  hamstar Dec 6 '09 at 3:21
3  
I am recalling that F8 was affected by the signing key compromise a while ago, and you needed to update the keys. If it has been a while since you have attempted any updates on the box, I would make sure that you have the "fedora-release-8-6.transition" package installed (rpm -qa|grep release) And if not, check out fedoraproject.org/wiki/… –  Alex Dec 6 '09 at 4:44
    
SHIZAM! WIN!!! Thank You!! –  hamstar Dec 6 '09 at 5:25

Try omitting the arch from the package spec:

[hamstar@tankian ~]$ sudo yum install php-pecl-apc
share|improve this answer
    
Yea I tried this too sorry, also didn't work... –  hamstar Dec 6 '09 at 3:16

Do a yum update and try again. This happens when your local package index is getting old and new versions of packages are beeing released.

Best wishes, Fabian

share|improve this answer
    
Thanks, I tried it but no cigar :( –  hamstar Dec 6 '09 at 3:19

The package isn't already installed, is it?

yum list installed | grep pecl
share|improve this answer
    
Oh it is installed, I was just using it as an example tho... replace php-pecl-apc with pyqt which is not installed and it does exactly the same, I've tried pyQt, pyqt, pyqt.i386 and pyQt.i386. –  hamstar Dec 6 '09 at 4:46
    
Updated question with output from a working yum install for a package that is already installed on my other FC8 box. –  hamstar Dec 6 '09 at 5:12
1  
Running "yum list installed 'pecl'" is much better than using grep. –  James Antill Dec 22 '09 at 22:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.