Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We recently rolled out IE8 to our organisation (2,500 people).

Given we had several legacy internal web apps that did not support IE8 (but worked fine in Compatibility Mode), we decided to put our internal domain into the Group Policy "policy list" of sites to be rendered automatically in Compatibility View.

This worked for almost everybody - compatibility mode turns on, and the compatibility button vanishes.

But there were seemingly about 100 users who did not get the policy setting (though they did get other IE8 policies).

I checked the registry, and the users are getting the policy list entries

[KEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\BrowserEmulation\PolicyList]

But they are not getting the "switch on" flag for compatibility view:

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\BrowserEmulation]    
"MSCompatibilityMode"=dword:00000001

Setting the registry flag, followed by a reboot, fixes the problem. I can bulk distribute this fix. But there must be a reason for this issue.

share|improve this question

3 Answers 3

I've never had occasion to have Group Policy Administrative Templates "partially apply" in the manner you're describing. My gut says that the root cause is that the specific GPO that sets the "MSCompatibilityMode" is either not applying to these 100 users.

Is the "MSCompatibilityMode" setting (called "Include updated Web site lists from Microsoft" in the Group Policy management console) being set for the users in the same GPO that contains your other IE8-related settings (the ones that you're talking about when you say "though they did get other IE8 policies")?

I'd run the Resultant Set of Policy (RSoP) MMC snap-in on an a user who is getting the right settings and a user who is not and compare the lists of GPOs applied.

share|improve this answer
    
Both registry options are correctly set in the GPO, and the users who have the GPO correctly applied have both registry entries. The RSoP report shows that the users are correctly getting the setting (and shows no errors). If the MSCompatibilityMode setting is for the MS list, then I'm very confused. Creating that registry entry fixed the policy list setting. –  christianlinnell Dec 6 '09 at 23:50

Be aware that HKEY_LOCAL_MACHINE takes precedence over HKEY_CURRENT_USER with regards to Internet Explorer Policies.

share|improve this answer

You are configuring the correct Group Policies. The websites configured in Group Policy will automatically open in Internet Explorer Compatibility mode, but they won’t display in Compatibility View Settings list in order to prevent users from removing the entries you specify. You can tell it's working, as the "Compatability Mode" button will not appear in the site you specify.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.