Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a laptop which has "recently" turned into the proverbial baby, and refuses to sleep through the night, or for that matter, through some days. I'm a little lost when it comes to trying to debug what is causing it to wake for no apparent reason.

EDIT:

Powercfg tells me:

C:\>powercfg -lastwake
Wake History Count - 1
Wake History [0]
  Wake Source Count - 1
  Wake Source [0]
    Type: Fixed Feature
    Timer Expired (RTC)

So it appears something is set an alert to wake the system up? But how would I find out what?

share|improve this question
    
What hardware, OS? –  Ivan May 17 '09 at 19:21
    
Vista (Home Premium) x64 on a HP HDX 18 –  Rowland Shaw May 17 '09 at 20:28
    
Have you tried the MCE Standby Tool? It has a debug log that may be helpful. slicksolutions.eu –  Andomar Jun 1 '09 at 9:53
add comment

6 Answers

You can use the PowerCfg utility to find out. It's part of Vista, no need to download it.

powercfg -lastwake

Will tell you what woke up your laptop.

To see all devices that can wake your computer, try:

powercfg -devicequery wake_armed

You can turn all these devices off with Device Manager, on the Power Management tab. Unselect "Allow this device to wake up the computer".

share|improve this answer
    
"ENE CIR Receiver" Looks like it doesn't need to be wake_armed, but that only lists keyboard and touchpad as other options, but I normally just open the lid to wake... Very useful too, though –  Rowland Shaw May 18 '09 at 17:52
    
Turn off the infrared controller in your BIOS-- I'm assuming you don't use it:) –  Andomar May 18 '09 at 17:55
    
I tried powercfg -lastwake, but it didn't show me the actual device that woke up my computer. I used the -devicequery option to investigate further, and apparently my network adapter was waking the machine up when any packet arrived on it. Disabling that setting through device manager fixed the "always waking up" problems. Thanks! –  Colen Oct 2 '09 at 16:32
add comment
up vote 3 down vote accepted

Tracked it down to be Windows Media Centre downloading the TV guide every four hours or so -- disabling that now lets the poor laptop sleep for as long as it likes.

share|improve this answer
add comment

Things to check:

  • Scheduled Tasks
  • Backup Jobs - (For example Windows Home server for home Other backup solutions for business)
  • Automatic Updates set at default (3am)
share|improve this answer
    
Only scheduled task that's run recently is the GoogleUpdateTask, and that isn't set to wake the computer to start. Norton 2009 log implies that the computer was woken at 1:33 this morning, 2:21 the other day, 2:11 the night before, 2:00 the day before. –  Rowland Shaw May 17 '09 at 20:36
add comment

Check its not related to your "Wake On Pattern Match" network adapter settings. Similar to wake-on-lan this setting can cause the network adaptor to wake up from unexpected things like ARP and NetBios over TCP (NBT) broadcasts -- which I suspect happen quite a lot on the average network.

For more info check out my blog post about random wake ups.

share|improve this answer
add comment

Not a great solution but have you tried using Hibernate instead of sleep? I'm just wondering if there are more wakeup events that apply to sleep than to hibernate. It might be that only the hardware with wake capabilities applies to Hibernate.

Just a thought...

share|improve this answer
add comment

I have a desktop that does the same thing. I can't be sure, but I swear it is related to keeping the browser open on certain websites. Maybe I'm correlating the wrong information, but it appears that certain websites will cause the desktop into thinking there is user action when it is really just push content from the website.

share|improve this answer
    
I know that's not the case in my situation, as I close things like browsers before I put laptop to sleep -- I was suspicious of that myself, though –  Rowland Shaw May 18 '09 at 17:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.