Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm on a Slicehost 256MB VPS with Ubuntu 9.04 (Jaunty). lighttpd is the only web server process running; it listens on port 80. My lighttpd.conf can be found here. I'm using Ubuntu's default logrotate setup for lighty.

At seemingly random times, lighttpd will stop logging. It is not correlated with log rotation--that is, the errors do not occur when logrotate kicks in. What happens is, I will verify that the server is serving files by hitting a URL with my browser, and I will verify that it is not logging by checking access.log and seeing that the GET request I just made is not there.

Using init.d to restart the process starts logging again, without truncating or rotating the log file. That is, new requests will be logged at the end of the existing access.log file.

There are no cron jobs running on this box.

Any ideas?

share|improve this question

2 Answers 2

These things are sometimes buffered. Are you sure that it is not logging at all? You may want to try hitting a number of different urls to check if the logs were just not written to disk yet. You may see the log entries appearing after a while.

share|improve this answer
    
I never saw the missing entries when I restarted the server process. So far I've lost 24, 12 and ~8 hours of logs at a time. –  Max Cantor Dec 8 '09 at 20:46
    
I don't know why it should just 'disappear'. Try sync-ing the disks to flush all disk operations. –  sybreon Dec 9 '09 at 0:44

I presume that you have enough disk space in the logging file system and that you have checked /var/log/messages.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.