Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to backup my SBS 08 (only C:) with Windows Server Backup. It fails a few minutes after it started:

Backup started at '08/12/2009 1:27:23 PM' failed as Volume Shadow copy operation failed for backup volumes with following error code '2155348022'. Please rerun backup once issue is resolved.

In the EventViewer i have lots of error :

VSS : 12289
SQLVDI : 1
MSSQL$MICROSOFT##SSEE : 18210
MSSQL$MICROSOFT##SSEE : 3041
SQLWRITER : 24583

All VSS ans SQL services are started. I have WSUS 3.0, Exchange 07. I don't have any third party backup software running at the same time.

share|improve this question
add comment

3 Answers

Do you have multiple partitions and if so, does the backup fail on those other non-system partitions?

Was SBS 2008 installed from the factory? In other words, is it an OEM installation? It's possible that the system partition is not marked as active. Have a look at this TechNet posting and see if you're willing to try the suggested fix: http://social.technet.microsoft.com/forums/en-US/winserverfiles/thread/d5daada2-b78b-4935-bd9e-80726c26c4a8/

Disclaimer: You will be using Diskpart as an admin. You can completely hose your system if you do not understand what you are doing. Read carefully. Act carefully. Live long and... well... you know. =)

share|improve this answer
    
Backup doesn't work on non-system partitions either. SBS wasn't installed from the factory. I don't find where to see if my C: is marked as active. Diskpart doesn't show me that. –  Bastien974 Dec 8 '09 at 19:49
    
Go into disk management, right-click on the C: drive and see if you can select "Mark Partition As Active". –  Wesley Dec 8 '09 at 20:43
    
Actually, let me add a bit more information to the previous. Go into disk management and in the graphical listing of volumes in the top half of the MMC, look at the "Status" column and see which volumes includes the word "Active" in its status. –  Wesley Dec 8 '09 at 20:46
    
None, all are "Healthy", and my C: is "Healthy (Boot, Page File, Crash Dump)" –  Bastien974 Dec 8 '09 at 20:53
    
That could potentially be part of the problem, but I also wonder why C: is not also marked as "System" and "Primary Partition". Strange. You'll have to weigh the risks of marking your system volume as active. You might want to take the server offline and do a complete image of it with a tool like Ghost before marking it as active using diskpart. –  Wesley Dec 8 '09 at 21:52
show 5 more comments

Do you have Antivirus running? Some AV's lock access to files and cause problems like this. Look in the event log for event 24583, which should provide some more information on what is failing. If you share that information it may help narrow down the problem.

Update: Too much to put in the comments to Bastien's update.

Several references on the Internet to the error you posted, many pointing back to this post: (http://www.sqlmonster.com/Uwe/Forum.aspx/sql-server/42606/SQL-Server-2005-SP2-Backup-Errors), where the solution was to re-register the VSS files:

net stop vss

From C:\windows\system32 register the following dlls and services:

regsvr32 ole32.dll
regsvr32 vss_ps.dll
Vssvc /Register
regsvr32 /i swprv.dll
regsvr32 /i eventcls.dll
regsvr32 es.dll
regsvr32 stdprov.dll
regsvr32 vssui.dll
regsvr32 msxml.dll
regsvr32 msxml3.dll
regsvr32 msxml4.dll
Regsvr32 EVENTCLS.DLL

net start vss

Also, on open regedit and search for EVENTCLS.DLL and ensure that the path to eventcls.dll is always on C:\Windows\System32 (according to the path on your server)

share|improve this answer
add comment

I had the same problem a few weeks back.

You need to check its not your Antivirus, so disable it for a few minutes and then try to run a backup. If this doesn't solve the issue, then try going into 'Services' and stop the 'SQL Server VSS Writer' - Now try to run a backup!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.