Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've recently installed linux using Sun's VirtualBox. I was wanting to play around with CouchDB, so I installed it onto the linux vm and have it up and running. Now, how do I get my host (Win7) to access the CouchDB database?

I did an ipconfig and it gave me what I'm assuming to be the vm's ip address as, as the ping times are less than 1ms. I tried accessing CouchDB with and it gives me nothing. Is there something else I have to do with CouchDB, linux, VirtualBox?


share|improve this question
up vote 4 down vote accepted

You need to check your host VM's IP and see if it's in the same network as the VM. If not, I'd suggest you set up your VM to use bridged, rather than NAT, networking. That way it'll appear to be just another client on your network without indirection.

Getting virtualbox's NAT network to be visible on your network is a layer of indirection that can be a headache to configure properly. A working bridging network configuration should clear that up a bit.

share|improve this answer
I went and changed it to bridged, and indeed my host can see my vm as a computer on my network. But I still can't access CouchDB from the host. I've went and changed the firewall to allow all traffic to port 5984 on the linux vm, but it still doesn't work? Any more ideas? – user28507 Dec 8 '09 at 17:12
First thing I'd do is get rid of complication to test it. Drop your firewall on the Windows computer and VM system, if you have them both on. Drop completely, then see if you can access it. Next check from the host to VM that you can see anything on that port with a port scanner. Then check on the Linux system that something is running at that port (netstat is your friend). Then check to see if there is a setting in couchdb that prevents IP's other than localhost from connecting. – Bart Silverstrim Dec 8 '09 at 17:38
Hmmm, weird. Just had to restart the vm. Now everthing works. Thanks for inputs! – user28507 Dec 8 '09 at 18:01

Also make sure CouchDB is listening on the VM's public IP address. By default CouchDB is bound to localhost only.

share|improve this answer
Do you mean change the binding address to If that's what you meant, then I did that already. – user28507 Dec 8 '09 at 17:16

PortQueryUI is a good Windows tool (like *nix NMAP) to see if another box is listening on a port.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.