Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am looking in SQL Server Configuration Manager, 'Protocols for SQLEXPRESS'

And IP1, IP2, IP3, IP4, and IPALL have the TCP Port blank.

Should that be 1433 or it will default to that?

share|improve this question
up vote 1 down vote accepted

If you want to use a specific port like 1433, you have to set it manually.

The default instance will use port 1433 by default, if TCP is enabled and the settings are left unchanged. A named instance will use a dynamic port by default. So the question really boils down to whether the Express instance is named or default (assuming the port number in the OP is a typo).


If the Configuration Manager says 'Protocols for SQLEXPRESS' it means the Express instance is a named one so it will use dynamic ports by default. You have to change the settings to use port 1433. .

share|improve this answer
how can I tell if its a named instance? .\SQLExpress works when logging in locally. – user2659 Dec 8 '09 at 20:10
It's a named instance and it's name is SQLEXPRESS. You would connect to a default instance using . alone or local or localhost. When you connect to it locally you connect using shared-memory and the TCP listennitng port is irelevant. – Remus Rusanu Dec 8 '09 at 20:44

If you are trying to get SQL Express to accept remote connections, it does not do this by default. You must enable this feature. Here is the KB for doing so. KB914277

share|improve this answer
thanks I read and did all that. server doesn't have windows firewall running (external firewall). – user2659 Dec 8 '09 at 18:42

By default SQL Express instances will use dynamic ports so the SQL Browser service is there to help clients connect. You can set a static port if you wish in SQL Configuration Manager.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.