Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I tried every time server out there but all I get is An error occured while Windows was synchronizing with *time server*

I also tried the Atomic Clock Sync by WorldTimeServer.com but then the time is offset by 2-3 seconds. I can't believe how hard it is to get an accurate time on my system. Does anyone have any ideas?

share|improve this question

2 Answers 2

The following KB article covers setting up (and troubleshooting) the ability of Windows to sync with an external NTP time source:

http://support.microsoft.com/kb/816042

In the troubleshooting section, it says:

Troubleshooting

For the Windows Time service to function correctly, the networking infrastructure must function correctly. The most common problems that affect the Windows Time service include the following:

  • There is a problem with TCP/IP connectivity, such as a dead gateway.
  • The Name Resolution service is not working correctly.
  • The network is experiencing high volume delays, especially when synchronization occurs over high-latency wide area network (WAN) links.
  • The Windows Time service is trying to synchronize with inaccurate time sources.
share|improve this answer
    
1. I tracert time.nist.gov and saw no dead gateway 2. Name resolution works 3. Does not explain why I get an error every time 4. I tried every time service –  user21316 Dec 8 '09 at 18:07
    
In the middle of that KB article are some steps that involve changing registry settings. Take a look at the section titled: Configuring the Windows Time service to use an external time source –  Sean Earp Dec 8 '09 at 18:23
    
Oh! I just remembered the solution that worked for me back in the day when I was building new computers... if the time/date (as set in Windows) is too far off from the real time (I don't know the threshold, maybe a day?), Windows will not update via NTP. Try setting the time to something close to the real time and try again. If that didn't work, just waiting a day or so usually resolved whatever random intermittent problem I was hitting. –  Sean Earp Dec 8 '09 at 18:25
    
If it's only 2-3 seconds off, though, I think that's permissible ntp drift, and it would resync properly after not long. –  user5336 Dec 8 '09 at 18:33
    
thanks for the answers, i am still at a loss though –  user21316 Dec 10 '09 at 11:12

I guest you sit behind a firewall. NTP uses User Datagram Protocol (UDP) port 123.

share|improve this answer
    
No, no firewall. –  user21316 Dec 8 '09 at 18:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.