Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I did

netstat -an | find /i "listening"

I get ports:

80, 135, 445, 1025, 1026, 1056, 3389

but no 1433?

I followed all the steps of allowing for remote connections that I could find, what could be the reason?

steps i did: 1. created a user account, tested on server and I can login using the server name .\express (using the IP doesn't work??) 2. in the server properties, allowed for both windows and sql authentication 3. surface area config: set local & remote connections, using both tcp/ip and named pipes (not sure I need named pipes, but just to get it to work I did both) 4. restarted both the server and sql browser service 5. sql config manager: protocoals for SQLExpress: shared mem, named, tcp/ip work.

Should I be connecting using:

233.234.234.234\SQLEXpress

or

233.234.234.234\SQLEXpress, 1433

or

233.234.234.234, 1433

or

233.234.234.234

I opend up ports 1433 (TCP) and 1434 (UDP) on the firewall. Server doesn't have windows firewall running.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

If you're working with SQL Express it's a named instance and by default it will install with dynamic ports configured. Check the IP Addresses tab of the TCP/IP properties dialog within SQL Configuration Manager. If you've got a 0 against your NIC or the All option at the bottom it's allocating a dynamic port (this is to make sure it doesn't clash with a default instance installed on the box and any other named instances). When it starts up it'll check the OS to see what ports are free and picks one.

Since you're going through a firewall it's easier to configure a static port for the instance which removes the need to have the browser service visible. In this case you should be able tp connect with:

IPAddress\SQLExpress, port

That's assuming you kept the default instance name of SQLExpress...

If this is a publicly accessible server then you're best of picking a non standard port number and ideally limiting access to SQL for VPN connections only but without more info on your set-up it's hard to say exactly.

share|improve this answer
    
meaning I should stop browser service, or you mean not open a hole int he firewall for it? –  user2659 Dec 8 '09 at 20:16
    
you the man! thanks ALLOT! –  user2659 Dec 8 '09 at 20:24
    
You shouldn't need to the browser service exposed if you're going via IP & specific port. It's only there to listen for SQL traffic and direct it to the required port if you've got instances using dynamic ports. –  Chris W Dec 9 '09 at 8:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.