Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

A little background. A server, running Windows 2003R2 (x86), with a RAID5 array, partitioned with 100GB for OS, the rest 2TB+ for data. 100GB is C:, data is D:. All fine.

Recently, due to drive failure, I am forced into re-installing the OS fresh. Of course, I do not want to touch the data partition. I boot from install disk, delete C:, re-create it (it takes C:) and begin install process. Drives get checked, and Windows installer makes some corrections on the data partition (D:). A reboots is forced.

After reboot install runs again, from CD, and now shows data partition as C:, with the rest un-partitioned. Creating a partition for the OS, assigns letter D:. I do not want that, but can't find a way to change it.

Anyone?

share|improve this question
    
Have you checked that the underlying raid partition for the OS disk is ok? Assuming that the recovery was to replace the failed disk and wait for the RAID 5 rebuild to finish. –  Sim Dec 9 '09 at 3:07
add comment

2 Answers

up vote 0 down vote accepted

Have you tried the Recovery Console as per How To Use the Recovery Console on a Windows Server 2003-Based Computer That Does Not Start?

Booting into that you could partition the OS drive properly using Diskpart, format it and assign the drive letter C.

As part of the install process the Data drive may have been chosen as the master boot drive so you would have to change that to be the OS drive.

Be careful with Diskpart and format etc to ensure you don't touch the data drive - make sure it is unmounted.

share|improve this answer
    
+1 for the recommendation on Diskpart. Assuming the Diskpart "assign" command isn't destructive (I can't format and loose data), this would work in my scenario. Data drive has already being assigned C:, so I will need to change it to Z: (for example), then change D: to C: and re-assign Z: to D: If this works, I will accept. –  user1797 Dec 9 '09 at 18:02
    
I hope it works out for you. Was it a hardware or software RAID set? –  Sim Dec 9 '09 at 22:43
add comment

I think you should mark first partition as active.

http://support.microsoft.com/kb/315261/en-us

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.